Plots.jl package ceases to work

Hi there,

I have been using Julia 1.82 on Windows 10 for nearly two years.
Up til now, the Plots.jl package has funcioned very well. Suddenly,
however, the package fails to work. Whenever I run a code that
includes the plot() command, an error pops up:

[ Info: Precompiling Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80]
Deps path: C:\Users\torei.julia\packages\FFMPEG\guN1x\src..\deps\deps.jl
ERROR: LoadError: FFMPEG not installed properly, run ] build FFMPEG, restart Julia and try again
[1] error(s::String)
@ Base .\error.jl:35
[2] top-level scope
@ C:\Users\torei.julia\packages\FFMPEG\guN1x\src\FFMPEG.jl:23
[3] include
@ .\Base.jl:419 [inlined]
[4] include_package_for_output(pkg::Base.PkgId, input::String, depot_path::Vector{String}, dl_load_path::Vector{String}, load_path::Vector{String}, concrete_deps::Vector{Pair{Base.PkgId, UInt64}}, source::String)
@ Base .\loading.jl:1554
[5] top-level scope
@ stdin:1
in expression starting at C:\Users\torei.julia\packages\FFMPEG\guN1x\src\FFMPEG.jl:1
in expression starting at stdin:1
ERROR: LoadError: Failed to precompile FFMPEG [c87230d0-a227-11e9-1b43-d7ebe4e7570a] to C:\Users\torei.julia\compiled\v1.8\FFMPEG\jl_7749.tmp.

I have tried the ] build FFMPEG command, to no avail.

Similar problems related to earlier versions of Julia have been noted, inviting a variety of suggested solutions, many of which didn’t seem to solve the problem.


What is your output of

using Pkg


We’ve had similar reports in the past. The problem usually involves some complicated enviornment with some out of date packages.

These commands yield the following output:

using Pkg

Status C:\Users\torei\.julia\environments\v1.8\Project.toml
[537997a7] AbstractPlotting v0.18.3
⌃ [336ed68f] CSV v0.10.13
⌃ [3da002f7] ColorTypes v0.11.4
⌅ [d38c429a] Contour v0.5.7
[717857b8] DSP v0.7.9
⌃ [a93c6f00] DataFrames v1.3.6
⌃ [31c24e10] Distributions v0.25.107
⌃ [5203de40] Dynare v0.5.8
⌃ [c87230d0] FFMPEG v0.2.4
⌅ [28b8d3ca] GR v0.72.10
⌃ [4b11ee91] Gaston v1.1.0
[7073ff75] IJulia v1.24.2
[41ab1584] InvertedIndices v1.3.0
[b964fa9f] LaTeXStrings v1.3.1
[2b0e0bc5] LanguageServer v4.5.1
⌃ [ee78f7c6] Makie v0.15.0
[2774e3e8] NLsolve v4.5.1
[58dd65bb] Plotly v0.4.1
⌃ [91a5bcdd] Plots v1.39.0
[438e738f] PyCall v1.96.4
[d330b81b] PyPlot v2.11.2
[fcd29c91] QuantEcon v0.16.6
⌅ [2913bbd2] StatsBase v0.33.21
[fdbf4ff8] XLSX v0.10.1
Info Packages marked with ⌃ and ⌅ have new versions available, but those with ⌅ are restricted by compatibility constraints from upgrading. To see why use status --outdated


There are some out of date packages there.

Let’s try a temporary environment first to see if that can successfully generate a plot.

using Pkg
Pkg.activate(; temp=true)
using Plots

Hi again,

This works for the example given. I have also successfully run a jl file with the plot() command.

Problem solved, as it seems.

Great thanks!

Well you might want to run an update on your main environment since it is not functional.

Do you mean a new version of Julia?


I meant.

using Pkg

However, upgrading Julia would be a good idea since you are currently using an unsupported version. The only supported verisons of Julia are Julia 1.6.7 and Julia 1.10.3 at the moment.

Yes, I’ll consider upgrading.

Great thanks again.