Plots.jl and (Cairo)Makie not compatible?

It seems I cannot have both Plots.jl and CairoMakie.jl or Makie.jl at the same time, or install them. I installed CairoMakie.jl with libfreetype 2.13 and it installed with no issues. Then when I tried to install Plots.jl, it raised a problem that libfreetype.6.dylib did not provide a version (although /usr/lib/) did provide the correct version.

So, if I activate an empty project say “OnlyPlots” and add Plots, it just works without any issue. Then in the same project, if I issue using CairoMakie, precompiling CairoMakie fails.
But otherwise, CairoMakie just works as is.

Is there a workaround so that I can have BOTH Plots and CairoMakie in the same project?

Arindam Basu

As I mentioned in Error in precompiling FFMPEG and Cairo and CairoMakie - #2 by giordano, I think you’re facing libGR issue preventing compilation · Issue #525 · jheinen/GR.jl · GitHub. I’m waiting for @jheinen there to find a resolution. Also in this case the solution for you should be to install

]add FreeType2_jll@v2.13.1 

I haven’t tried it as I can’t reproduce your error on a different version of macOS

1 Like

To be honest, I have no idea how to fix it on the GR side, as installing Cairo Makie seems to downgrade FreeType2_jll (v2.13.1+0 ⇒ v2.10.4+0 ). I locally tested GR with FreeType 2.10 - 2.13.1 static libraries.

@arinbasu: Also I’m wondering, what ...although /usr/lib/) did provide the correct version. means. Where should this version come from?

@arinbasu can you please update your packages and try again? You should get GR_jll@0.72.9+1, from [GR] Add explicit dependency on `FreeType2_jll` by giordano · Pull Request #7170 · JuliaPackaging/Yggdrasil · GitHub, which I believe fixes your problem.