Plotly not working on MacOS

Taking my first steps with Julia and am really excited about it. However I can’t get Plotly plotting to work on MacOS. It works fine with GR backend

Here’s what I do
using Plots
plotly() # Choose the Plotly.jl backend for web interactivity
plot(rand(5,5),linewidth=2,title=“My Plot”)

results in an error

Error showing value of type Plots.Plot{Plots.PlotlyBackend}:
ERROR: UndefVarError: plotattributes not defined

Have you added the Plotly.jl/PlotlyJS.jl package? I’m not sure 0.7/1.0 is working right now for Plotly though - at least PlotlyJS doesn’t want to build for me.

Plots still is in a bit of a transition phase for Julia 1.0 where most things work but there is the occasional bug, so the Plotly integration seems to be broken but should be fixable quickly (I’ve opened an issue here). Probably better to stick with GR for the time being.

EDIT: turns out this is fixed already on Plots master, so you can also do ] add Plots#master to get the fix right now

1 Like

Sorry I did not. I assumed Plotly was part of Plots. When adding I ran into some issues. First HttpParser did not build. Fixed that by using the fix proposed in this bug report and then had to move Plotly and PlotlyJS to master. It all builds fine but as soon as I want to plot it still throws the same error