Pkg not updating to latest version of registry

I have released a few updates of PlotlyBase. These were released with JuliaRegistrator and the associated PRs have been merged into General. On Github, the latest master branch shows that PlotlyBase has versions through 0.8.0 (see here)

However, when trying to add PlotlyBase, I can only get up to Version 0.7.0 (this prevents me from using 0.7.1, 0.7.2, or 0.8.0)

I tested in a fresh julia install (via docker image) and got this:

❯ docker run --rm -it julia:1.6.2 julia
Unable to find image 'julia:1.6.2' locally
1.6.2: Pulling from library/julia
33847f680f63: Pull complete 
bebe3e6f4fec: Pull complete 
c675740a024e: Pull complete 
Digest: sha256:da7de79a62fadca6fa3e125656fa6053258db5ff339f753fa817b7819f60682d
Status: Downloaded newer image for julia:1.6.2
              _
  _       _ _(_)_     |  Documentation: https://docs.julialang.org
 (_)     | (_) (_)    |
  _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
 | | | | | | |/ _` |  |
 | | |_| | | | (_| |  |  Version 1.6.2 (2021-07-14)
_/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

(@v1.6) pkg> add PlotlyBase
 Installing known registries into `~/.julia`
      Added registry `General` to `~/.julia/registries/General`
  Resolving package versions...
  Installed JLLWrappers ───────── v1.3.0
  Installed UnPack ────────────── v1.0.2
  Installed Preferences ───────── v1.2.2
  Installed PlotlyBase ────────── v0.7.0
  Installed Parameters ────────── v0.12.2
  Installed Requires ──────────── v1.1.3
  Installed DocStringExtensions ─ v0.8.5
  Installed Parsers ───────────── v1.1.0
  Installed OrderedCollections ── v1.4.1
  Installed Kaleido_jll ───────── v0.1.0+0
  Installed LaTeXStrings ──────── v1.2.1
  Installed JSON ──────────────── v0.21.1
 Downloaded artifact: Kaleido
   Updating `~/.julia/environments/v1.6/Project.toml`
 [a03496cd] + PlotlyBase v0.7.0
   Updating `~/.julia/environments/v1.6/Manifest.toml`
 [ffbed154] + DocStringExtensions v0.8.5
 [692b3bcd] + JLLWrappers v1.3.0
 [682c06a0] + JSON v0.21.1
 [b964fa9f] + LaTeXStrings v1.2.1
 [bac558e1] + OrderedCollections v1.4.1
 [d96e819e] + Parameters v0.12.2
 [69de0a69] + Parsers v1.1.0
 [a03496cd] + PlotlyBase v0.7.0
 [21216c6a] + Preferences v1.2.2
 [ae029012] + Requires v1.1.3
 [3a884ed6] + UnPack v1.0.2
 [f7e6163d] + Kaleido_jll v0.1.0+0
 [0dad84c5] + ArgTools
 [56f22d72] + Artifacts
 [2a0f44e3] + Base64
 [ade2ca70] + Dates
 [8bb1440f] + DelimitedFiles
 [f43a241f] + Downloads
 [b77e0a4c] + InteractiveUtils
 [b27032c2] + LibCURL
 [76f85450] + LibGit2
 [8f399da3] + Libdl
 [37e2e46d] + LinearAlgebra
 [56ddb016] + Logging
 [d6f4376e] + Markdown
 [a63ad114] + Mmap
 [ca575930] + NetworkOptions
 [44cfe95a] + Pkg
 [de0858da] + Printf
 [3fa0cd96] + REPL
 [9a3f8284] + Random
 [ea8e919c] + SHA
 [9e88b42a] + Serialization
 [6462fe0b] + Sockets
 [2f01184e] + SparseArrays
 [10745b16] + Statistics
 [fa267f1f] + TOML
 [a4e569a6] + Tar
 [cf7118a7] + UUIDs
 [4ec0a83e] + Unicode
 [deac9b47] + LibCURL_jll
 [29816b5a] + LibSSH2_jll
 [c8ffd9c3] + MbedTLS_jll
 [14a3606d] + MozillaCACerts_jll
 [83775a58] + Zlib_jll
 [8e850ede] + nghttp2_jll
 [3f19e933] + p7zip_jll
Precompiling project...
 15 dependencies successfully precompiled in 5 seconds

(@v1.6) pkg> st
     Status `~/.julia/environments/v1.6/Project.toml`
 [a03496cd] PlotlyBase v0.7.0

shell> cat ~/.julia/registries/General/P/PlotlyBase/Versions.toml
["0.2.0"]
git-tree-sha1 = "be07f136ef88dc1e412c9af36400925d68c6759a"

["0.2.1"]
git-tree-sha1 = "baed09282affd03b1f667e26f0909e5246db38c0"

["0.2.2"]
git-tree-sha1 = "e0d6ca3c4ccf9291d12450f7c616912db9ca6b92"

["0.2.3"]
git-tree-sha1 = "310d954da14daf6c5655197972e88a839930e0c9"

["0.2.4"]
git-tree-sha1 = "b13351821b91bdd9db5c4ea5d401bb5d5ad296eb"

["0.2.5"]
git-tree-sha1 = "685c331de7712539c1f0d06e061fe57320bba5c9"

["0.2.6"]
git-tree-sha1 = "59105ae9f523831c9108eaeeac88beb827402e13"

["0.2.7"]
git-tree-sha1 = "0c4b19d828257f51009682e537e29799386acc81"

["0.3.0"]
git-tree-sha1 = "3bf75544fb56640f6f7ccd95e052b12589cc7474"

["0.3.1"]
git-tree-sha1 = "c50438d8affbd77ebcb46f46e276cc66cabc61bd"

["0.4.0"]
git-tree-sha1 = "e0fa23d66404e4df898e1a8300a40808d8aa30e2"

["0.4.1"]
git-tree-sha1 = "b33809ab5a35bf41d1fd7c851b52e32004392933"

["0.4.2"]
git-tree-sha1 = "c29d6bb03de64d8f5661d6e10d65aa214b9550c2"

["0.4.3"]
git-tree-sha1 = "5eb8913f14a48db2f62ffad7a2e7f30bfd5e9396"

["0.5.0"]
git-tree-sha1 = "c329de0db4a1986d8d54eed53a05464110240c8f"

["0.5.1"]
git-tree-sha1 = "74a507dccef08c08d07f244a6e58ea3a3852d146"

["0.5.2"]
git-tree-sha1 = "1fcca9e3e25a43a33c9acbc5384ba47e7a5bd698"

["0.5.3"]
git-tree-sha1 = "f20d4669281187c9e9d75820f8ec95e88131fc1e"

["0.5.4"]
git-tree-sha1 = "bca220daa9705b891a42c6ce0c20534a3196e73e"

["0.6.0"]
git-tree-sha1 = "aafd9d49797e1b7854488c17d2b7682798d6836a"

["0.6.1"]
git-tree-sha1 = "90e1f9bf3c1cd82009fe4e4d575d7098a193581b"

["0.6.2"]
git-tree-sha1 = "6c5a286f9a20eb349af1d8eed33db78f02704b46"

["0.6.3"]
git-tree-sha1 = "64ae210cbf2b0e8ee1a65edc1d932b5771d60c8b"

["0.6.4"]
git-tree-sha1 = "b29c63ad0b1fb313bf42f6bb1260959cbaf57b8b"

["0.6.5"]
git-tree-sha1 = "72f53b06f6326a5f2bf904919c497424ed5c6231"

["0.6.6"]
git-tree-sha1 = "d906c0f0ea2569217917f8eb455581af048370b8"

["0.6.7"]
git-tree-sha1 = "fd1b34c4306de3f324adb012253099efb6125922"

["0.7.0"]
git-tree-sha1 = "96c1e98b848d9cb6cea5088f1ef1b008e17a45a9"

julia> using Downloads

julia> path = Downloads.download("https://raw.githubusercontent.com/JuliaRegistries/General/master/P/PlotlyBase/Versions.toml")
"/tmp/jl_Y6OW40"

julia> println(String(open(read, path)))
["0.2.0"]
git-tree-sha1 = "be07f136ef88dc1e412c9af36400925d68c6759a"

["0.2.1"]
git-tree-sha1 = "baed09282affd03b1f667e26f0909e5246db38c0"

["0.2.2"]
git-tree-sha1 = "e0d6ca3c4ccf9291d12450f7c616912db9ca6b92"

["0.2.3"]
git-tree-sha1 = "310d954da14daf6c5655197972e88a839930e0c9"

["0.2.4"]
git-tree-sha1 = "b13351821b91bdd9db5c4ea5d401bb5d5ad296eb"

["0.2.5"]
git-tree-sha1 = "685c331de7712539c1f0d06e061fe57320bba5c9"

["0.2.6"]
git-tree-sha1 = "59105ae9f523831c9108eaeeac88beb827402e13"

["0.2.7"]
git-tree-sha1 = "0c4b19d828257f51009682e537e29799386acc81"

["0.3.0"]
git-tree-sha1 = "3bf75544fb56640f6f7ccd95e052b12589cc7474"

["0.3.1"]
git-tree-sha1 = "c50438d8affbd77ebcb46f46e276cc66cabc61bd"

["0.4.0"]
git-tree-sha1 = "e0fa23d66404e4df898e1a8300a40808d8aa30e2"

["0.4.1"]
git-tree-sha1 = "b33809ab5a35bf41d1fd7c851b52e32004392933"

["0.4.2"]
git-tree-sha1 = "c29d6bb03de64d8f5661d6e10d65aa214b9550c2"

["0.4.3"]
git-tree-sha1 = "5eb8913f14a48db2f62ffad7a2e7f30bfd5e9396"

["0.5.0"]
git-tree-sha1 = "c329de0db4a1986d8d54eed53a05464110240c8f"

["0.5.1"]
git-tree-sha1 = "74a507dccef08c08d07f244a6e58ea3a3852d146"

["0.5.2"]
git-tree-sha1 = "1fcca9e3e25a43a33c9acbc5384ba47e7a5bd698"

["0.5.3"]
git-tree-sha1 = "f20d4669281187c9e9d75820f8ec95e88131fc1e"

["0.5.4"]
git-tree-sha1 = "bca220daa9705b891a42c6ce0c20534a3196e73e"

["0.6.0"]
git-tree-sha1 = "aafd9d49797e1b7854488c17d2b7682798d6836a"

["0.6.1"]
git-tree-sha1 = "90e1f9bf3c1cd82009fe4e4d575d7098a193581b"

["0.6.2"]
git-tree-sha1 = "6c5a286f9a20eb349af1d8eed33db78f02704b46"

["0.6.3"]
git-tree-sha1 = "64ae210cbf2b0e8ee1a65edc1d932b5771d60c8b"

["0.6.4"]
git-tree-sha1 = "b29c63ad0b1fb313bf42f6bb1260959cbaf57b8b"

["0.6.5"]
git-tree-sha1 = "72f53b06f6326a5f2bf904919c497424ed5c6231"

["0.6.6"]
git-tree-sha1 = "d906c0f0ea2569217917f8eb455581af048370b8"

["0.6.7"]
git-tree-sha1 = "fd1b34c4306de3f324adb012253099efb6125922"

["0.7.0"]
git-tree-sha1 = "96c1e98b848d9cb6cea5088f1ef1b008e17a45a9"

["0.7.1"]
git-tree-sha1 = "2becde6f78be533c60b461793d6664dc86a1ac2f"

["0.7.2"]
git-tree-sha1 = "245b9fcf3f2dd43230613df66cc5e43821dc3e34"

["0.8.0"]
git-tree-sha1 = "18321330fc2ea8005305a857301ef56abf77a920"

Any idea why I can’t get anything past 0.7.0?

What happens if you do

pkg> add PlotlyBase@0.8.0

?

Tells me available versions end with 0.7.0

(@v1.6) pkg> add PlotlyBase@0.8.0
   Resolving package versions...
ERROR: Unsatisfiable requirements detected for package PlotlyBase [a03496cd]:
 PlotlyBase [a03496cd] log:
 β”œβ”€possible versions are: 0.2.0-0.7.0 or uninstalled
 └─restricted to versions 0.8.0 by an explicit requirement β€” no versions left

1 Like

Seems like this must be it.

It has been over 3 days since 0.7.1 was released I still can’t get it through the β€œnormal” usage of pkg mode.

Is this something that is expected to take this long? Is there another issue here that I need to resolve?