I am attempting to update my packages on Julia 1.5.1 and it tells me that it cannot contact

Messing around with curl, I receive the domain-specific redirect fine (, but attempts to reach that address time out for me. If I switch to http://, same problem with a different error message. Pings to that address also fail.

This is true both from my work VPN and my home desktop.

For the moment my workaround is to clone the github JuliaRegistries/General repo into my .julia/registries directory, but is the default for things like downloading artifacts (with github as a fallback) so even if I’m capable of downloading them it takes more than twice as long due to timeouts. I’d like to resolve this. Please let me know if there’s any more necessary information.

Hard to diagnose all the possible problems—it seems up for me. Possible you got it while it was having a problem? Can you reach or (They all work for me.)

1 Like

Neither of those pong for me.

Just straight pongs successfully.

Even on my phone (LTE), I cannot ping from Termux

Had a friend try to ping it from one state south and he can’t get a response either.

It all works now. If anything changed on Julia’s end, that probably fixed it. If not, one of the series of tubes between the mid-east coast and the servers got unblocked.