Package Manager, Gitlab newer version not liking SSH keys

A funny thing happened the other day. We have an internal gitlab server. I have a registry setup. The registry was working fine.

On the IT side they did something to gitlab when they were adding required expirations to ssh keys and things stopped working for the package manager. I think I was still able to connect to gitlab normally through gitbash.

So to make the key have an expiration date, I created a new key and supplied it to gitlab. Normal git was happy, but package manager was not and could never verify the private key location until it timed out after 4 attempts to identify it. I fussed around for hour or so. Then I decided to put the old key back in again… since it made a new expiration date, this made everything happy again. Package manager working again by magic.

I went on my way.

Now I have a colleague setting up gitlab for the first time. Everything works with the ssh except for the package manager. Unfortunately he doesn’t have an old key to go back to. What’s the fix to this mystery?

I considered using JULIA_PKG_USE_CLI_GIT. Is that the only fix? I haven’t tried it yet. Seems odd it worked until a week ago…

Best Regards,