Package "LinearAlgebra"

Since I have to use debugger, I’m going back to JuliaPro with Julia-v0.6.4.1. While testing a package, I was bounced and told that I need package “LinearAlgebra”. But failed installing it. Is that because the package no long exists? Any workaround? Thanks!

julia> Pkg.add("LinearAlgebra")
ERROR: unknown package LinearAlgebra
macro expansion at .\pkg\entry.jl:53 [inlined]
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335

LinearAlgebra is a standard library introduced in Julia v0.7 containing Base.LinAlg from Julia v0.6, so it is not available on Julia v0.6 A package that requires it will not work on Julia 0.6 either.

Oh, I see. Thanks!

Really want to say: I’d be very happy to elope with anyone who can give me a proper and robust debugger which works for v1.0!

2 Likes

You can try Rebugger.jl, which is apparently very cool, though I haven’t tried it properly myself.

Here: https://github.com/timholy/Rebugger.jl

(The name seems to indicate that you can use to re-introduce old bugs, but I don’t think that’s the case!)

1 Like

In fact, I have tried. Rebugger is really really nice and I really really want to say ‘thank you’ to the author. But it is just too buggy to handle some of the big packages that I’m working with. So I had to give up.