No luck with WGLMakie in IJulia

I’m hoping to get basic interactive plots (e.g., manipulation of 3D axes) in IJulia. But following the basic instructions in the docs has not worked on both linux and MacOS.

I’m using Julia 1.6, running IJulia.notebook(). In the first cell I execute

using JSServe

which runs with empty output. Then I try

using WGLMakie

After about 10 seconds I get Warning: Waiting for page sessions to load. Then after a couple of minutes, the cell finishes but the output is again blank. No window is opened, and there is “Nothing to see” on port 9284, which seemed relevant in some other posts.

I am clearly missing something fundamental! What do I need to do?

I wasn’t able to install ijulia in the recent years… But I actually got it working recently, but haven’t had time to make sure that wglmakie works since then. The one time i tried, I also noticed that it doesn’t work at the moment, guess it bitrotted since nobody tested it in the last year’s.

That’s life on the bleeding edge. Thanks for your response.