New package version not appearing on Juliahub

I had recently registered a new version of my package “Nbdev.jl” - source -GitHub - sapal6/Nbdev.jl: Create Julia packages from Notebooks

When I search my package on juliahub, i can see the package’s name and new version appearing in the search results but when I click on my package name then it displays the attached error.

I also tried to add the package in one of my environment but then the following error occurred -

I can see an automated comment on the registrator pull request -

This is the link to the pull request. I am not sure that would it take some time for my package to appear in Juliahub or is there some other issue.

Yes, the second portion of that 404 message is the case here: JuliaHub hasn’t yet built the documentation and info pages for your package. It is a regularly recurring task and should get to it soon.

This explains the lack of information/documentation on the package page but does this also explain the second issue i.e. when I try to “add” my package in the pkg terminal, it displays error. Sorry but this is only my second time since publishing package to julia, so I am having a few questions here.

Ah, I missed that second portion — that’s due to this warning:

Warning: Some registries failed to update:
    - `C:\Users\family\.julia\registries\General` — registry dirty
@ Pkg.Types C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\Types.jl:1246

Probably the easiest and quickest fix for this is to delete (or move) the C:\Users\family\.julia\registries\General folder. Somehow you have modified your registry locally and now Julia is refusing to update it.

Ah I myself didn’t notice this. I think this might be because in the same registry I had installed the Dev package locally.

I will clean it as suggested by you and will post an update.

It usually is not necessary to modify the registry. Consider using Pkg.develop in the future. You can provide local paths or git URLs directly.


It worked as you suggested. Now installing the package using add works.