NeuralPDE.jl vs NeuralNetDiffEq.jl

Hi all,

I’m trying to use the NeuralPDE package, but when I run ‘import Pkg; Pkg.add(“NeuralPDE”)’ I get the error:

ERROR: The following package names could not be resolved:

  • NeuralPDE (not found in project, manifest or registry)

I think I’ve seen that NeuralPDE.jl used to be called NeuralNetDiffEq.jl, which I was able to add. I was also able to run the example at by replacing “NeuralPDE.NNODE…” with “NeuralNetDiffEq.NNODE…”. So can I use NeuralNetDiffEq in place of NeuralPDE for the time being? and will NeuralPDE be added to the registry at some point?

My first post here, let me know any issues.

It should already be in the registry. When did you last update?

Not sure, but I reinstalled recently. Would I need to update Julia or JuliaPro, and how?


JuliaPro still can’t find it after updating, but I can get the package when I run Julia from the Start menu. So it looks like its a problem with JuliaPro and I can probably live with that.

Btw I thought your workshop last weekend was extremely good.