Need help with Quadrature while using NeuralPDE

Hi, I am new to Julia. I am trying to run examples from NeuralPDE. Examples were working earlier, but today after I pulled the NeuralPDE repository, I am getting the following error:

ERROR: LoadError: Failed to precompile Quadrature [67601950-bd08-11e9-3c89-fd23fb4432d2] to /home/user/.julia/compiled/v1.7/Quadrature/jl_dBxI90. Stacktrace:

I tried running status:

(@v1.7) pkg> status
Status ~/.julia/environments/v1.7/Project.toml
[aae7a2af] DiffEqFlux v1.47.1
[ffbed154] DocStringExtensions v0.8.6
[587475ba] Flux v0.13.3
[a75be94c] GalacticOptim v3.4.0
[9d3c5eb1] GalacticOptimJL v0.1.0
[7073ff75] IJulia v1.23.3
[961ee093] ModelingToolkit v8.13.2
[315f7962] NeuralPDE v4.9.0
[91a5bcdd] Plots v1.29.0
[67601950] Quadrature v2.0.0

Not sure why this is happening. Can someone please guide me?

Can you share the error message? Quadrature was just renamed today so I wonder if that might have something to do with that, but I’d have to see the full message.

Oh I found and fixed it. I botched a bit of how the deprecation for the Quadrature → Integrals package renaming happened, so the old version didn’t dispatch properly (for reference, @deprecate QuadratureProblem IntegralProblem makes QuadratureProblem a function instead of a type so it doesn’t dispatch with ::QuadratureProblem :sweat_smile:). I got that cleaned up and added a downstream test there, so if you update things should all be good. Cheers and thanks for the report.

Its working in the terminal now, thanks Chris!

However, I keep getting the same error in the notebook. Not sure what I am doing wrong. I launch the notebook from julia using notebook().