Neptune doesn't load properly in browser

I included Neptune in the REPL with using, then ran, but when I choose a new notebook, it doesn’t load to the point of seeing a ready-to-use notebook. Basically it looks like an empty white screen. What is the most likely solution?

I thought it might have to do with the browser’s settings, maybe with privacy or security settings such as popup settings, but to be honest, I don’t know.

Hey @Ouji ,

Welcome to the Julia Community! :wave:
Glad you posted here!

I think @compleat was the creator of Neptune but I am unsure as to how well it is still supported - I cc’d them to see your question.

Out of curiosity, why are you using Neptune instead of Pluto?
Do you need the non-reactivity offered by Neptune?
If Neptune is no longer supported, perhaps check out IJulia and Jupyter notebooks as that may give you what you need.

Again, welcome to the community!

~ tcp :deciduous_tree:

1 Like

Neptune is still supported, when I can find the time.
For what you are asking, it sounds ike a browser issue.

I wish I could help more.

1 Like

Thanks @TheCedarPrince. Very much appreciated. I chose Neptune because it seemed more standard and straightforward without the reactivity. I also kept VSCode in mind. I think they support Jupyter notebooks now, don’t they?

@compleat Thanks for the work.

Yes and I think VSCode Jupyter notebooks even support Julia kernels now although @davidanthoff would know here than I would.
Yea that makes a lot of sense - I enjoy the non-reactivity of Neptune but Pluto now has the ability to disable cells if you need so you can kinda get the non-reactivity in some ways in standard Pluto.

As an aside, I would love to see a “non-reactive mode” come to Pluto someday or if Neptune’s work could be reabsorbed into Pluto in some way.

If I’d try Pluto, I think Pluto might still not load properly in the browser, due to Neptune being its fork. So I wonder if it’s worth trying. But honestly, I suppose I don’t know until I’d try.

I wonder if I shouldn’t just use VSCode and get it over with: it looks like it’s the most versatile option, especially if it supports Julia and Juypter well, though it seems to use more RAM overall than it used to.

It probably takes less than 5 minutes inluding all precompilation to do ]add Pluto; using Pluto; to see whether Pluto works, so it’s not a big investment?

FWIW Jupyter notebook support in the Julia extension is very new and I would say still rought around the edges, at the minute IJulia is probably the more robust way of using Jupyter notebooks.

I do like the recent JupyterLab standalone app, and have had very good experience with it, in conjunction with IJulia. Personally, I find VSCode to be too ‘busy’ an environment for me - flexibility comes at a price.

In cases where the browser seem to be blank and not loading, it might be worth opening the developer console to check if there are errors logged on it.

It happend to me multiple times (when trying to modify some Pluto internals) that the package would not load at all and the only error I could see where on the browser side, and not on the julia CLI side.

@nilshg Thank you. I suppose you are right about that quick try. Maybe I’ll do that.

@compleat You mean the desktop application, right? I considered it as well as its browser counterpart, but does the desktop version use much RAM or is it slow? If it uses Electron, I’d think it’d unnecessarily use much RAM and CPU, or that it might have memory issues. I don’t like to leave room for that.

@disberd Very much appreciated. I might try that, but if I do, what exactly should I be looking for? Any tips?

I checked the logs in the browser.

After trying to open the Getting Started sample notebook, there were about 36 warnings that looked like more or less like The FetchEvent for the URL resulted in a network error response: the promise was rejected."

There were about 60 errors, and they had two main sorts: uncaught (in promise) TypeError: Failed to fetch at sw.js:[location], and failed to load resource: net::ERR_FAILED.

When I tried to open a new notebook, pretty much the same happened, I think: about 45 warnings of the same sort above, and 69 errors of the same sort mentioned above.

May or may not, it’s a relatively old fork at this point, I think some relevant parts of Pluto have been rewritten during that time, especially building and loading the browser specific frontend and bundle. Pluto moved to using Parcel IIRC.

1 Like

Thanks for your comment.
I tried it out after all. As expected, it didn’t load. Pretty much the same errors occurred.

Which browser are you using? This probably shouldn’t be happening, might be worth opening an issue if there’s a reasonably standard browser configuration under which Pluto doesn’t work (although tbh I would be surprised given how many people are using Pluto).

1 Like

Try using Firefox or Chrome for Pluto, these are the officially supported browsers. Other browsers may or may not work.
In addition, please make sure to use the latest versions for both the browsers and for Pluto, as well as Julia 1.6 or newer.
If your error persists, please file an Issue at, as @nilshg suggested.

Alright, I might do that. I need to get some time for it and get around to it, before it would come to it.

As I mentioned in another thread, I was starting to think my approach to SQL and Julia might’ve been wrong. With it, I think the way I approached choosing to use Neptune/Pluto/etc. might’ve been wrong too. Sorry if I’ve wasted your time.