My dependency changed one of its dependencies - can't build my package anymore


I pushed a minor changed to my Julia’s package repo and got the following error during the Documenter build:

ERROR: LoadError: LoadError: ArgumentError: Package Polynomials does not have MakieCore in its dependencies:
- If you have Polynomials checked out for development and have
  added MakieCore as a dependency but haven't updated your primary
  environment's manifest file, try `Pkg.resolve()`.
- Otherwise you may need to report an issue with Polynomials

Apparently, my own package expects that Polynomials requires MakieCore, when it doesn’t. Since this error is new, I went to the Polynomials.jl repo to check this. Indeed, just yesterday they pushed a commit with name remove unneded makiecore dep (#576). My problem seems to sprout from that.

In the Manifest.toml file of my own project, Polynomials’ dependencies are:

deps = ["LinearAlgebra", "RecipesBase", "Setfield", "SparseArrays"]
git-tree-sha1 = "f2281d0e9826cbdd16e6acfe736231850fed3f0f"
uuid = "f27b6e38-b328-58d1-80ce-0feddd5e7a45"
version = "4.0.10"

    PolynomialsChainRulesCoreExt = "ChainRulesCore"
    PolynomialsFFTWExt = "FFTW"
    PolynomialsMakieCoreExt = "MakieCore"
    PolynomialsMutableArithmeticsExt = "MutableArithmetics"

    ChainRulesCore = "d360d2e6-b24c-11e9-a2a3-2a2ae2dbcce4"
    FFTW = "7a1cc6ca-52ef-59f5-83cd-3a7055c09341"
    MakieCore = "20f20a25-4f0e-4fdf-b5d1-57303727442b"
    MutableArithmetics = "d8a4904e-b15c-11e9-3269-09a3773c0cb0"

Thus, MakieCore appears as a weak dep, and PolynomialsMakieCoreExt as an extension. I commented both their lines and pushed again, but I got the same error.

How do I resolve this conflict? I ran Pkg.resolve() with no effect.

Maybe try deleting all the Manifest.toml files in your source file tree.