MPI Configuration


I’m trying to configure MPI.jl. I installed OpenMPI according to these instructions:

I’ve confirmed that /usr/local/bin is in $PATH. Then I followed this page to try and configure MPI:
but when I run
`julia --project -e ‘ENV[“JULIA_MPI_BINARY”]=“system”; using Pkg;“MPI”; verbose=true)’

It gives me the error:

   Building MPI → `~/.julia/packages/MPI/biSVL/deps/build.log`
[ Info: using system MPI
ERROR: LoadError: libmpi could not be found
 [1] error(::String) at ./error.jl:33
 [2] top-level scope at /Users/sam/.julia/packages/MPI/biSVL/deps/build.jl:76
 [3] include(::String) at ./client.jl:457
 [4] top-level scope at none:5
in expression starting at /Users/sam/.julia/packages/MPI/biSVL/deps/build.jl:64
┌ Error: Error building `MPI`: 
└ @ Pkg.Operations /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.5/Pkg/src/Operations.jl:949

It seems others have this problem and fix it by adding something to the /.bash_profile like

export JULIA_MPI_PATH=/usr/local/

But I am still getting the same error when I try to build MPI. I’m not sure if the symbolic link is pointing to the right folder? I’m not sure what I’m looking for.

Any help would be appreciated! Thanks!