Makie in Jupyter?

I’m trying to install and use Makie in a Jupyter notebook: No luck. Tried the installation of WGLMakie: No luck. Does anyone have this working on a Windows10 machine?

If it helps, the code below worked - once - and then it wouldn’t work again.

using AbstractPlotting, Makie

x = rand(10)
y = rand(10)
colors = rand(10)
scene = scatter(x, y, color = colors)


I have the same problem. I’m trying the first makie example on a jupyter notebook on a mac with wglmakie, and no graph.
Should this be working or not? I couldn’t tell from the documentation.

please do a clean install of either CairoMakie, GLMakie, WGLMakie and the following should work, no need for using Makie or using AbstractPlotting.

using GLMakie
scatter(rand(10), rand(10))

and all the examples here are done in Jupyter notebooks


Indeed, GLMakie works fine on my mac, as does CairoMakie. I tried only a Jupyter notebook.

It’s just that I’d like to run Makie in a docker container running Debian. It doesn’t have X11, so GLMakie won’t work. (And I don’t want X11.) CairoMakie works fine in the container, so it’s the only one.

My question is simply if WGLMakie should work in either of these scenarios or not. It would probably add value if it would run inside the container, in the notebook, or actually the browser on the host.

Hi, I am new to julia, and I installed GLMakie in jupyter notebook, but I can’t run the code, for example"using GLMakie", and then it will show error. Could you please help me?