Latest Makie / Julia v1.0.0, scene debugging?


I’ve been able to run the Makie examples in Julia-1.0.0 on OSX without trouble. :slight_smile:

Currently, I’m attempting to visualize a DAG in 3D. I import the data into Dictionaries, and then process them into arrays for feeding into Makie. For my first attempt, I manually created an example DAG, enough to force 3D rendering, and was able to view it successfully.

However, now that I moved to a larger dataset, I get a blank scene when I run my script. I tried scrolling around, but nothing is visible, not even the axises.

Liberal applications of ‘@show’ leads me to believe that a) my data is imported correctly and b) dumped into the arrays correctly. One array for spheres / nodes, and one array for lines between nodes.

So, what’s the best way to debug scene? $searchengine didn’t yield much, unless I want to know more about someone named “Julia Makie” :wink:

Is it possible to create a minimal working example, that I can run and look at?

Hi Simon,

This request has been overcome by events. :slight_smile: I was waiting for it to be moderated before replying.

I got past this particular hurdle by sheer luck. While my data was imported correctly, I was using raw seconds since epoch for the z-axis. This led Makie to make some good but unfruitful guesses as to how to position the camera and what to look at. It seems to default to lookat(0). Which doesn’t work so well with points around (0, 0, 16e9) or so.

I now process my data so I get one point per event, resulting in a range along the axis of 1 to a couple hundred. I also manually position the camera and camera direction.

Here’s an example of what I have so far: