KeyError: key 'C' not found when using modelingtoolkitize command

I am using the modelingtoolkitize command to convert a large system of ODEs to symbolic expressions in order to perform Structural Identifiability Analysis. However, I am receiving the following error:

KeyError: key ‘C’ not found

The same command worked fine in other large models so I do not know what happened.

Thank you!

This would need an MWE.

The code is confidential so unfortunately, I cannot share it. :frowning:

However, I played around with it, and it looks like that when I change the way of I initialize the problem by replacing the function we use in the lab to just set every initial condition equal to one, it resolves the issue with the modelingtoolkitize command.

In my understanding, Structural Identifiability does not depend on the initial values, so it does not really matter how we initialize the problem.

Now I am getting warnings (see example) regarding some floating numbers when I run the StructuralIdentifiability.jl but hopefully the algorithm can take care of it.


Warning: Floating points are not allowed, value 1.6611295681063124e-10 will be converted to 1//6020000000.


Yes, it needs integer or rational values.