Jupyter cannot create Julia notebook

Hi everybody !
I’m a new Julia user with great experience in Python.
Nevertheless I wrote already around 200 programs, mainly translations of previous Python counterparts.
I’m under linux mint 20.
i installed julia from their site and installed it in /opt/julia-1.6.1 according some suggestions found here and there. Julia REPL is started by the command /opt/julia-1.6.1/bin/julia
I’m using for now two editors Atom with plugin Juno and Jetbrains Pycharm (community) with plugin julia. I gave to both the correct path for julia interpreter and everything works. Each of these two products have merits and demerits but I consider them globally as good products.
Now I decided to give Jupyter notebook a try.
So I loaded the IJulia package and I can start Jupyter by the notebook() command from interpreter using IJulia it works !
I installed too ‘anaconda’ (full product) from their site and it was installed according their suggestion and with my agreement in ~/anaconda3. I can also launch Jupyter notebook from inside anaconda using ~/anaconda3/bin/anaconda-navigator and their special icon in the browser. Everything works fine and finally I get the same result with both methods.
So my purpose is to edit and RUN julia files from Jupyter.
And here is the problem which happened :
Jupyter notebook allows me to create python files and to run them and to edit text files, and that’s it.
Seems that Jupyter cannot detect the installation of Julia. Everybody says that IJulia package creates the link. for me it doesn’t work. Option of creating a ‘Julia notebook’ is never proposed by the dropping list.
I read a lot and tried a lot of would-be solutions for this problem. Nothing worked. Some mention an anaconda prompt ??? I don’t now what it is and I cannot access this on my system .
I think that’s simply due to a wrong initialization of some environment variable, but which one and how to access and change it ?
So I’m stuck, for 2 days already.
If somebody can help.
I can answer your questions more accurately and make some suggested tests.
Thank you in advance for your help.

1 Like

Excuse me I found the solution on the same forum :

]
build IJulia

is the secret formula !
Thanks the author of this post.

4 Likes

But this question about the mysterious “anaconda prompt” remains. i need it for a few settings…

As you are on Linux, just use the terminal, that is it: https://docs.anaconda.com/anaconda/user-guide/getting-started.html.

Thank you for your help. But …
I know very well this document you’re given a link for, very useful and very well done.
Of course I thought about your proposition that what they call ‘anaconda prompt’ was just the usual prompt from the terminal, but no!
Every time I try a suggested ‘command’ the system cannot find it, even if I open the terminal in anaconda home directory…
So I think it’s something different. they say how to get it from windows systems but not on linux, even in the document which you mention.
Actually I want simply to change the default working directory. For now it’s my home directory and I want to change it for ~/Documents/jupyter/Julia/
So I will try to create manually some config file inside .jupyter/ according suggestion from related discussions on the web, but I’m not sure that jupyter will be aware of it and watch content when starting.
However it’s surprising that such well-done application doesn’t propose in the ‘settings’ the possibility to fix this point.

jupyter notebook --notebook-dir /home/myname/Documents/Jupyter
This works !
No help needed anymore for the moment.
Thanx again for reading.

My mistake, it works only for one time (one session).
After closing and restarting everything is forgotten …

Solution found here :
https://shanyitan.medium.com/how-to-change-the-working-directory-of-jupyter-and-jupyter-lab-on-windows-environment-bbe5a5a99f05
Actually so complicated for so simple thing. Really for geeks !
But again I notice that no choice of location for html exports they are directed all of them by default, without asking, to the default download directory.
Maybe I should read fully, till the end, this interesting romance called ‘jupyter_notebook_config.py’.
No time for this for the moment !

About html exports …
Till now I got used to Pycharm conversion.
the same program converted by Pycharm : 5K
by Jupyer : 500 k 100 times heavier and quite impossible to read and edit.
So I will stay with JetBrains for this purpose.