From Zero to Jupyter-lab on Linux for Julians?

I have a new computer since the last time I used Jupyter-lab. I use Jupyter-lab just for Julia, and so have no need for python stuff other than as infrastructure for things like Jupyter.

I installed IJulia.jl and Conda.jl on the new computer, and tried

using IJulia
julia> notebook()
[ Info: running `/home/dlakelan/.local/bin/jupyter notebook`
Process(setenv(`/home/dlakelan/.local/bin/jupyter notebook`; dir="/home/dlakelan"), ProcessExited(1))

Evidently something in my home directory is telling IJulia that it should use some old install location of jupyter that is no longer there or no longer a valid install. How can I get IJulia to start from scratch and use Conda.jl to build the stand-alone version?

Also does the stand-alone version work with lab?

Well I never figured out how to make Conda.jl do its thing, but I did wind up installing miniconda3 and then julialab according to instructions online. All I can say is I pity the fools that put up with that stuff in python… The whole install process took literally over an hour and in the end miniconda decided it was just ok for it to go ahead and CHANGE MY BASH PROMPT which made me just about lose my cuckoo and the fix is documented here: python - Anaconda: disable prompt change - Stack Overflow and as someone said there

" This is deeply worrying. If anaconda thinks it has the right to edit .bash_profile in a way which changes the prompt, what else does it (mistakenly) think it has the right to do? Turns out, it also adds to the beginning of PATH so that, for example, curl is redefined. Ouch! I’m treating this as malware. – Adam Chalcraft"

Thank you Julia devs for getting package management pretty much right!

1 Like

Am still hoping someone will answer the question of how to force IJulia/Conda.jl to treat the whole install as if it were a “first time” install, as described in the README

The first time you run notebook() , it will prompt you for whether it should install Jupyter. Hit enter to have it use the Conda.jl package to install a minimal Python+Jupyter distribution (via Miniconda) that is private to Julia (not in your PATH ).

Will mark that as the answer if someone figures it out :wink:

On my phone so can’t check but I think there’s an ENV variable called PYTHON you should be able to set to an empty string, then build Ijulia again

Have you tried

] build IJulia

I did, twice…
Will try out that ENV var thing.

Note: the home directory is the same as before on my older computer, so evidently there’s some stuff in my home directory that makes IJulia think it’s already set up to work with the older install.

At this point, having done the whole conda thing, it’s probably best if I just leave it alone and don’t touch things that aren’t actually broken (yet) :wink: It is in fact running the conda based install.

From the manual

"
You can try setting ENV[“JUPYTER”]=""; Pkg.build(“IJulia”) to force IJulia to go back to its own Conda-based Jupyter version (if you previously tried a different jupyter)
"

1 Like

Perfect. Who would have thought to RTFM :rofl:

:laughing: to be fair it’s on the very last page. I just remembered looking this up once before. Recently build has always worked but I might have installed Anaconda first in those computers.