JuliaFEM cannot be precompiled

Hi julia experts,
I installed and built JuliaFEM right after installing Julia1.5 but when I type ‘using JuliaFEM’, I got error:

ERROR:LoadError:LoadError:Evaluation into the closed module ‘Calculus’ breaks incremental compilation because the side effects will not be permanent.This is likely due to some other module mutating ‘Calculus’ with ‘eval’ during precompilation-don’t do this.

I thought this might be related to version of julia,so i changed julia1.5 into julia1.4 and julia 1.3 and tried again but it still doesn’t work.
Thanks for your time.

3 Likes

Hi Alex2,

I came across the same problem.
Do you have a solution for this probleme already?

Best regards,
Nils

I think this is fixed already: https://github.com/JuliaFEM/JuliaFEM.jl/issues/257

Maybe I will need to make a new release?

1 Like

Hi guys,

I installed Julia and JuliaFem today, and came across the same problem.

Using Julia v"1.6.0", and only have the following packages installed:
“Juno” => v"0.8.4"
“JuliaFEM” => v"0.5.1"
“Atom” => v"0.12.31"

Any tips for a rookie?

Thanks and best regards,
Joakim

This also seems interesting alternative: GitHub - gridap/Gridap.jl: Grid-based approximation of partial differential equations in Julia

We haven’t had resources to keep developing JuliaFEM. In the future I would like to see a joint effort in developing FEM packages that would work smoothly together. Maybe it will need a better starting point that we have at the moment or maybe we already have that in the recently created or updated packages.

Thanks guys for fast replies!

I took a look at both Gridap.jl and Ferrite.jl and to a complete beginner in Julia, both seems like feasible starting points for my project.