Julia v1.2.0-rc1 is now available

Hello Julians,

The first release candidate for Julia v1.2.0 is now available. Binaries can be found at the usual download page https://julialang.org/downloads/. There are source tarballs available as github releases, or of course you can check out and build the release-1.2 branch.

Please test if you can, and file any issues you encounter at https://github.com/JuliaLang/julia/issues. If you maintain any packages, this is a good time to add CI for 1.2, check compatibility, and tag new versions as needed.

Thank you and happy coding!

56 Likes
14 Likes

Is there an option to run the tests on Travis already? Thought adding 1.2 in the julia versions is sufficient but as it not really released yet it seems not to be the case.

Edit: It somehow works on Mac?
https://travis-ci.org/lanl-ansi/Juniper.jl/builds/539622490

1 Like

I can download https://julialang-s3.julialang.org/bin/linux/x64/1.2/julia-1.2-latest-linux-x86_64.tar.gz, but for some reason Travis can’t

1 Like

I have trouble with Travis and v1.2 on Linux, too:

Installing Julia
0.01s$ CURL_USER_AGENT="Travis-CI $(curl --version | head -n 1)"
0.00s$ mkdir -p ~/julia
0.17s$ curl -A "$CURL_USER_AGENT" -s -L --retry 7 'https://julialang-s3.julialang.org/bin/linux/x64/1.2/julia-1.2-latest-linux-x86_64.tar.gz' | tar -C ~/julia -x -z --strip-components=1 -f -
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
The command "curl -A "$CURL_USER_AGENT" -s -L --retry 7 'https://julialang-s3.julialang.org/bin/linux/x64/1.2/julia-1.2-latest-linux-x86_64.tar.gz' | tar -C ~/julia -x -z --strip-components=1 -f -" failed and exited with 2 during .

OS-X runs fine.

Is there any reason the REPL simply wouldn’t start (this is on a Mac running 10.14.4)? When I start Julia it just aborts with no error.

One thing that would be cool: whenever a first release candidate for a new minor version is released, some bot automatically opens PRs against all registered packages. Those PRs add the new version to the travis and appveyor scripts.

18 Likes

The main problems with that kind of mass-PR approach are:

  1. If we use a GitHub bot, then it has to be installed on the package for it to be able to open a PR. This could be solved if, for example, we have Registrator (or TagBot) itself make a PR.
  2. If we automate some solution ourselves for mass-PRs, then we run into (a) Github rate limits and (b) a lot of downloads of Git repos (even if they are shallow clones, that’s still a lot of data.

From my experience making mass PRs to the JuliaDiffEq and JuliaDynamics organizations, the abuse detection on Github is pretty easy to trigger, so you might have to wait an hour - or more - before the timeout expires. This is pretty annoying.

The Registrator/TagBot approach, however, might work. I just don’t want yet another bot to install for a normal Julia package repo.

Just my 2¢.

2 Likes

I’ve had a successful CI run on linux now, so I guess Travis has recovered from whatever weird caching issue (or otherwise) it was having.

1 Like

Fails for me with 1.2.0 (tried also 1.2). Runs fine with 1.1.0
https://travis-ci.org/GenericMappingTools/GMT.jl/builds/540994588?utm_source=github_status&utm_medium=notification

This is exactly the same error that I was getting previously.

I figured out my issue with the REPL not starting -> for some reason I needed to start it with sudo. Is there any local configuration that would force that?

sorry for the spam, but I’ve corrected my issue. I had the env var JULIA_BINDIR set to point to the 1.1 bin directory. I removed that and the 1.2 REPL now opens without issue.

2 Likes

I’m wondering whether those Windows binaries were built using the latest LLVMBuilder nor not.

1 Like