Julia v0.7.0 has been released

release

#1

It’s here, folks: Julia v0.7.0, the latest full release version. Binaries are available for macOS, Windows (32- and 64-bit), Linux (i686 and x86-64), and FreeBSD (x86-64). You can download them from https://julialang.org/downloads. Note that the download links for 0.6 have been moved to the old releases page.

We feel that 0.7 is the best release yet, and we hope you’ll try it out and see why. Happy coding!


#2

Can I now checkout release-0.7 to stay on the most current release?


#3

Better to checkout the tag, git checkout v0.7.0.


#4

Can you elaborate on why it’s better? It’s a minor inconvenience to have to switch if it changes to 0.7.1, but I liked being on release-0.6 so I could always git pull && make and be sure that I was on the latest release.


#5

The branch release-0.7 is not the same as the latest release.


#6

What is “on the latest release”? The latest release is the one with tag 0.7 and not the release-0.* branch.


#7

I mean the latest release for that version - are they still not the same? I get that it won’t switch over to 1.0 when that’s released. I want to be up-to-date, but not on the bleeding edge. I thought that’s what the release tags were for?


#8

yes you want to track release-0.7. Its just that you will get updates prior to the 0.7.1 release which potentially could be unstable. So just build not daily but only when you get triggered by a new release.


#9

I tried to build v0.7.0 with USE_INTEL_MKL=1, ARCH=x86_64 and MARCH=native, and the build failed with little description of the error. Last few lines of make -j6:

Scanning dependencies of target llvm-readelf
[ 98%] Generating ../../bin/llvm-readelf
[ 98%] Built target llvm-readelf
[ 98%] Linking CXX shared module ../../lib/BugpointPasses.so
[ 98%] Built target BugpointPasses
[100%] Linking CXX executable ../../bin/yaml2obj
[100%] Built target yaml2obj
[100%] Linking CXX executable ../../bin/opt
[100%] Built target opt
Makefile:60: recipe for target 'julia-deps' failed
make: *** [julia-deps] Error 2

EDIT:
My fault; I had forgotten to source the Intel compiler variables (usually /opt/intel/bin/compilervars.sh).
Now it builds successfully.


#10

I’m curious about testing Julia v. 0.7.0. However, I also need to check that some packages work with v.0.7.0… So:

  • How to I see whether v.0.7.0 is supported by packages? With the new web page layout, I don’t know where to find info on compatibility…
  • Specifically, I checked “IJulia” (but will also check Plots, DifferentialEquations, etc.)
    – How can I see which version of Julia which works with IJulia?
    – With IJulia for v. 0.7.0, will IJulia = Jupyter Notebook, or Jupyter Lab? With Jupyter Lab, do I start IJulia as:
julia> using IJulia
julia> lab()

?


#11

Thank you. – Just saw the Pkg3 live stream, great stuff, so excited about the new package manager (hope it works out as intended;)


#12

It does. Its great!


#13

Can you try re-running make until you get the actual error? It should be buried in the output somewhere.


#14

Yes, I’ll start a single-threaded build tonight.


#16

Forgive me; I was too hasty. I had simply forgotten to source Intel’s compiler variables and it couldn’t find the MKL libs… Build successful.