Julia on iOS and Android

could be corrupted image?
make clean will fix?
could be if you have julia installed from my repo it messes with it since at some point its loading the wrong libraries?
what ever is occuring i will be updating the branch so it installs and adding documentation explaining how the android linker, LD_LIBRARY_PATH etc can mangle things because android linker does not behave like a normal linker does. Which requires workarounds particularly if you doing something weird like compiling julia on it…

But first i have to finish testing gcc-8 so it doesn’t break anything if you install it.

okay time fill in some infomation with regards to complinig on device. Arm is the hard one so lets go through the issues.
First the ram requirements for compiling is higher than it is for running it. Android also has a habit of killing processes that use lots of cpu and slowly require more and more ram… the device i was using to compile it died and tried 3 other devices and they fail. It needs ram.

secondly last time i checked arm still required libunwind so if you are getting bus errors during compile it could be its not installed or maybe libuv needs it can’t recall.

the android linker is deliberately designed to be stupid so you have to tell it the order to search libraries via LD_LIBRARY_PATH. To use a compiled in place version you have to add the julia libs LD_LIBRARY_PATH before system LD_LIBRARY_PATH. this means you can’t use dynamically linked lib version of libuv that julia uses at the same time as the termux libuv.so since you need to have the LD_LIBRARY_PATH first pick up julia libs then termux system libs. Solution was to simply use statically linked julia libuv.

1 Like

juliabox.com runs on iOS, i reccomend iPhone but have used it on iPhone aswell. You can run code, install packages and it is cloud based, so all your code can be downloaded on another device.

JuliaBox does not run on iOS; JuliaBox is hosted on, I’d imagine, Linux servers (or maybe a *BSD?). However, JuliaBox is accessible from iOS, since JuliaBox’s interface is through a web browser. That is a key distinction; you can’t write code that works in a cross-platform manner that works the same on iOS as it would work on a desktop system. That is to say, things like filesystem operations, device access (cameras via VideoIO, Vulkan-accelerated graphics if any exist, etc.) would not work on JuliaBox accessed from iOS, while these things would work on a regular desktop running native Julia.

1 Like

Just saw this:

https://developer.apple.com/documentation/bundleresources/entitlements/com_apple_security_cs_allow-jit

From what I understand, you can request permission now for your app to use writable executable memory (if Apple grants this specific entitlement to your app). Would that mean that Julia on iOS would be possible, at least potentially?

I don’t think many people would try using Julia on iOS for serious tasks - still, having Julia in your pocket is kinda cool. Recently, during a presentation where I was advocating for Julia and was pointing out that it can pretty much run anywhere (demonstrating live on a Jetson Nano), someone asked “well, does it run on your phone?”. The fact that I could pull my phone out and show a Julia console on it (thanks, @its-pointless!), silly as it seems, definitely made an impact. So it’s actually not so pointless at all (pardon the pun). :wink:

Disclaimer: I’m not a frequent iOS user, and certainly not an iOS developer, so I may be reading this completely wrong.

3 Likes

Unfortunately it looks like these permissions are for building mac apps that run on the MacOS App Store (such as Building -- and releasing -- a fully self-contained Application written in julia).

Unfortunately I’ve since let my Developer account lapse, so Paddle Battle is no longer on the app store… I’ve tried putting it back, but had problems getting everything to work. :cry:

Would that mean that Julia on iOS would be possible, at least potentially?

But so no, I don’t think this means anything for iOS compatibility. :cry:

1 Like

Ah, darn! :frowning:

In case anyone finds the following helpful/inspiring, here’s a short description of how Swift playgrounds work on iOS w/out a JIT:

Julia might be able to do something similar, at least for functions/call-trees marked as “expensive” in some fashion (doing this for every function would probably be prohibitive). I suspect they have linker customizations and other special sauce to make it work well.

2 Likes

It seems that running Julia on Android may now just be as simple as installing Termux and running apt-get install julia?

I did try and start down the path of building from source and followed the directions here, but I think that may not have been necessary…

2 Likes

Looks like maybe I spoke too soon. The result of trying to add Distributions:

1 Like

It says unable to locate package julia for me

1 Like

Figure it out!

1 Like

Haha thanks! That’s awesome! I got it installed via those same instructions as well. :slight_smile: Neat fun!

$ pkg install wget
$ wget https://its-pointless.github.io/setup-pointless-repo.sh
$ bash setup-pointless-repo.sh
$ pkg install julia  # julia 1.2.0 fork

6 Likes

I’m just compiling Julia inside iSH for iOS which provides a virtualized x86 Linux environment. Will let you know how it goes (binary download of Julia was not working, see https://github.com/tbodt/ish/issues/259 ).

By the way, if it is possible to create something like full x86 emulation iSH (it uses a kind of JIT written in assembly) there must be some similar way to get Julia JIT to run natively with iOS restrictions. Anyone mad enough to dive into this ? :wink:

5 Likes

How do we do that! Can you please elaborate on how to run Julia on termux!

1 Like

Check out my guide here. I found ti searching for Android in this forum

2 Likes

Thank even I found the same guide but I want to connect it a jupyter app and run from browser

Up to now julia can be built for iSH but unfortunately freezes on executing code. One reason could be unimplemented syscalls related to memory management and tracing (e.g. gdb doesn’t work as iSH doesn’t support ptrace syscalls). Anyway, performance wouldnt bee too nice due to emulation.

As a heads up to users of Termux, it looks like Android has had some changes to their security model in Android 10 which may affect (and possible eliminate) Julia functionality:

1 Like