Julia Language Server and VSCode Issue on HPC


I am having some issues with the language server. I’ll describe what I am trying to do first.

I am getting my development environment set up on a new cluster. I want to be able to use the Julia Extension via VSCode remote development.

I am using Julia 1.8.0, VScode version 1.80.1 and Julia Extension version 1.47.2.

I was able to SSH into the cluster, clone my git repo for development, and instantiate it. Note I had to instantiate it on a compute node and not a login node because of limitations on number of cores the login node allows you to use (I could have set precompilation tasks to 1 but that would have taken ages).

When I start Vscode though the Julia language server crashes. I looked in the output and I see the following.

Activating project at `~/.vscode-server/extensions/julialang.language-julia-1.47.2/scripts/environments/languageserver/v1.8`
[ Info: Starting the Julia Language Server
OpenBLAS blas_thread_init: pthread_create failed for thread 156 of 256: Resource temporarily unavailable

The message about OpenBLAS blas_thread_init repeats until it is 255 of 256.

Then a fairy long stack trace is given with the following at the top:

ERROR: LoadError: IOError: could not spawn `MY/PROJECT/PATH/julia-1.8.0/bin/julia -Cnative -MY/PROJECT/PATH/julia-1.8.0/lib/julia/sys.so -O0 -g1 --startup-file=no -O0 --output-ji MY/PROJECT/PATH/.vscode-server/data/User/globalStorage/julialang.language-julia/lsdepot/v1/compiled/v1.8/Compat/jl_CDFTIb --output-incremental=yes --startup-file=no --history-file=no --warn-overwrite=yes --color=auto -`: resource temporarily unavailable (EAGAIN)

Which is followed by this message

The Language Server failed to precompile.
Please make sure you have permissions to write to the LS depot path at

I made sure that the directory v1 is read and writable for users, groups, and other and I still get the same error.

Any clues on what might be causing this or how to resolve it?

I had a similar experience in

Could you check the result of ulimit -a? Could you also try a recent Julia version (1.9.0+)?

Here is what I get when doing ulimit -a on the login node.

max user processes              (-u) 1028898

I will give 1.9 a try later tonight.

I couldn’t wait lol.

1.9.2 seems to have fixed the issue. Thanks for the suggestion!

1 Like