Julia fills entire RAM when Intellisense activates for inserting unicode characters via TAB completion

As the title indicates, I was using the TAB completion sequences of certain unicode inputs (\cdot, \rho, \alpha, \beta…) when I noticed that the Intellisense stopped working entirely. Then the TAB completion for the unicode stopped showing suggestions. Further, typing “\pi” and hitting tab does not print the symbol but prints verbatim “\pi\t” (where ‘\t’ is the tab character). The tab completion worked fine in a standalone Julia and this only occurred in VS Code. That was the behavior I noticed. Then as I continued to attempt to get the Intellisense and unicode tab completion to work in VS Code, I noticed that somehow Julia began an infinite loop and completely consumed all the RAM on my machine (which is a lot).

So this problem started last night and I researched other threads on here and saw that this is a recurring problem but none of the fixes really worked for me. I have tried completely uninstalling Julia 1.4.2 and VSCode 1.46.1 and reinstalling it with no other packages (I did run update from the Pkg prompt though), and the problem re-surfaced. I am at the point where I have to monitor Julia in Task Manager, and it happens with the unicode TAB completion without fail each time.

Is there a legit fix to this? Does this problem occur with Atom/Juno?

Just a heads up, I am very new Julia so please offer suggestions with this in mind. Thank you in advance for your help.


See https://github.com/julia-vscode/julia-vscode/issues/1443. This appears to be a recent problem in VS code.


@odow I read your post on the github forum. I experienced the same issue with the memory staying alive after manually killing the app (multiple times). I think VS Code had also started multiple instances of julia.exe on some of those occurrences.

Can you try the unicode TAB completion to reproduce on your macOS and see if you can “reliably trigger it”? Make sure you give the Intellisense time to list the auto-completes as you enter the greeks, et al. I think that’s what starts/triggers the infinite loop and then the RAM usage just blows up exponentially until it consumes all RAM. Something in the way Julia talks to VS Code’s auto-complete is my guess.

Side note, in the meantime I am using Atom/Juno and it seems to not have this issue.

Can you try the unicode TAB completion to reproduce on your macOS and see if you can “reliably trigger it”?

Already tried, and it doesn’t trigger.

1 Like

Anybody got any suggestions? I’d like to be able to use Julia+VS Code again. Thank you in advance.