Julia exits when I import Plots package in Atom


Julia exits in atom’s REPL when I type in “using Plots” and prints out the following error:

signal (11): Segmentation fault: 11
in expression starting at no file:0
_platform_strcmp at /usr/lib/system/libsystem_platform.dylib (unknown line)
Allocations: 71808137 (Pool: 71791494; Big: 16643); GC: 154
Julia has exited.

The same happens if I run any scripts that include “using Plots” in atom. When I run the script in my terminal, it takes an unusually long time and still shows no plots. Although, if I start Julia from the terminal and run a simple plot in the interactive shell, it plots fine.

I also tried it in nteract’s notebook and the plots work just fine.

What versions of Julia and Plots are you using? What system are you on?

In case you are on Julia 1.0.x: This is a known and very unfortunate bug that I have no idea how to debug. I’d recommend upgrading to a newer Julia version if you can.

Upgraded to Julia 1.4 and everything is working fine now. Thank you.

1 Like