Julia 1.7.3 Build Fails on M1 MAC Pro

I am trying to compile Julia (V 1.7.3) on M1 Mac Pro but it seems to be failing with Error 138 :

  CC src/llvm-remove-ni.o
    CC src/llvm-julia-licm.o
    CC src/llvm-demote-float16.o
    LINK usr/lib/libjulia-internal.1.7.dylib
    LINK usr/lib/libjulia-internal.1.dylib
    LINK usr/lib/libjulia-internal.dylib
    JULIA usr/lib/julia/corecompiler.ji
/bin/sh: line 1: 91643 Bus error: 10           /Users/nitinarora/src/julia/usr/bin/julia -C "apple-a12" --output-ji /Users/nitinarora/src/julia/usr/lib/julia/corecompiler.ji.tmp --startup-file=no --warn-overwrite=yes -g0 -O0 compiler/compiler.jl
make[1]: *** [/Users/nitinarora/src/julia/usr/lib/julia/corecompiler.ji] Error 138
make: *** [julia-sysimg-ji] Error 2

anyone knows how to get around this ?


don’t, it’s known to not work before 1.8, use 1.8+

If you’re trying to compile yourself Julia v1.7.3 because there is no official build for that platform, well the reason why there is no official build of v1.7.3 for aarch64-apple-darwin is precisely because compilation fails and no one is ever going to fix it. The entire v1.7 series on this platform is plagued by many problems (including very frequent segmentation faults), solved in v1.8, but the fixes can’t be backported because they’re mostly related to an upgrade of llvm, which can’t be backported. As already suggested above, just don’t use v1.7.


Thanks for the replies.

Looks v1.8.0-rc3 worked !!