Julia 1.7.0 ignores SIGTERMs (Signal 15)

Julia 1.6.3 handled SIGTERMs nicely, so Ctrl+C worked like expected. However, Julia 1.7.0 ignores these signals. To reproduce simply start two Julia-processes with the two versions and call pkill julia (where pkill is supported of course)

Is this expected? Ctrl+C seems to be a pretty default way to cancel a process so it’s a bit weird that this is not respected…

Edit: I must correct: SIGTERMs are not ignored in 1.7.0 but it breaks the runtime… So the Julia-REPL with 1.7.0 hangs itself when calling pkill julia

Edit 2: Ctrl+C sends SIGINTs and not SIGTERMs. However, behavior is the same


I can repro this. master works fine though.

I tried it with the [64-bit (glibc)]… Isn’t that master?

No, that’s the 1.7 release. SIGTERM works fine with a source build on commit 73f46aa290 (which is what I had lying around already).

Oh I see… Should I open an issue on the repo? Or probably it will be fixed anyway, if it is in the latest commit, right?

There’s already an issue open regarding this.

This should be fixed in the next point release of Julia 1.7.


Nice, thanks!