Julia 1.0.3 testing period

release

#21

Ha ha. The double negative.
I think Kristoffer is saying the debug version will not be included from v1.0.4 and v1.1.0

(the PR to remove debug will be in those versions)


#22

OK, not that important but I’m confused because he also said


#23

The PR to remove debug “will not be in v1.0.3 but will be in 1.1.0 and 1.0.4.”

Hence, debug will not be included from those later versions.


#24

Right, I got it now. While I was talking on the dll itself he was referring to the action to remove it. :blush:


#25

Thanks for listing the offending lines, which lead me to this thread.
Deleting the second entry [[Pkg-93b6d6de857dc88e665d2c64397852ab9701ba24]]
was necessary, but not sufficient.

With these commands the build was clean:

git checkout  v1.0.3
# clean the repo; both the following commands were mandatory.
git reset --hard
make cleanall
# verify
git status
HEAD detached at v1.0.3
nothing to commit, working tree clean
# build
make -j $(nproc)
make docs

#26

What did you end up doing? I’ve tried cleaning most things now but I’m still getting this.


#27

I made a bunch of noise about it on Slack (which was ignored), added it to the 1.1 milestone on GitHub (also ignored). Ultimately 1.0.3 was released without fixing this. I’m not sure how that was deemed acceptable, but I was on vacation at the time so there wasn’t much I could do about it.


#28

The issue was not ignored, in fact the issue (https://github.com/JuliaLang/julia/issues/30379) got fixed by the PR (https://github.com/JuliaLang/julia/pull/30422).

No, 1.0.3 was released with fixing this, https://github.com/JuliaLang/julia/pull/30422 was merged into release-1.0.


#29

@andreasnoack try run git fetch --tags --force.


#30

The issue is still open, so that’s a bit hard to tell.


#31

Just tried this but I’m still getting the error. I initially tried building v1.1 but I’m also seeing this when trying to build master (same local repo).


#32

That sounds odd then. Are you sure it is the same warnings?


#33

Pretty sure. In both cases, I get

client.jl
docs/Docs.jl
Base  ─────────── 26.535253 seconds
error during bootstrap:
LoadError("sysimg.jl", 491, ArgumentError("Package Base64 not found in current path:\n- Run `import Pkg$
 Pkg.add(\"Base64\")` to install the Base64 package.\n"))
rec_backtrace at /data/andreasnoack/julia/src/stackwalk.c:94
record_backtrace at /data/andreasnoack/julia/src/task.c:217 [inlined]
jl_throw at /data/andreasnoack/julia/src/task.c:417
require at ./loading.jl:823
jl_fptr_trampoline at /data/andreasnoack/julia/src/gf.c:1854
jl_apply_generic at /data/andreasnoack/julia/src/gf.c:2209
do_call at /data/andreasnoack/julia/src/interpreter.c:323
eval_value at /data/andreasnoack/julia/src/interpreter.c:411
eval_body at /data/andreasnoack/julia/src/interpreter.c:625
jl_interpret_toplevel_thunk_callback at /data/andreasnoack/julia/src/interpreter.c:885
Interpreter frame (ip: 40)
Core.CodeInfo(code=Array{Any, (87,)}[
  Expr(:call, Base.getproperty, :Base, :(:is_primary_base_module)),
  Expr(:gotoifnot, SSAValue(1), 87),
  <newvar #<3>>,
  <newvar #<8>>,
...

which looks slightly different from Stefan’s error message, though.


#34

Oh, I thought we were talking about https://github.com/JuliaLang/julia/issues/30379 (which is what Stefan was talking about).

Regarding that error, only thing I can think is that the LOAD_PATH is messed up somehow. Maybe you can print it out before the stdlibs are loading.


#35

That was unfortunate.

It’s

docs/Docs.jl
LOAD_PATH: ["@stdlib"]
Base  ─────────── 26.609290 seconds

right before the stdlib section of sysimg.jl. Is that right?


#36

That is what it should be afaik.


#37

I recognize this as a variant of https://github.com/JuliaLang/Pkg.jl/issues/965 so try to clean usr (e.g. https://github.com/JuliaLang/julia/pull/30075#issuecomment-442151605), or at least wipe out stdlib/Pkg.


#38

Thanks. That did it.