Julia 0.5 is now officially unmaintained

release

#1

Given the current pace of development of Julia v0.7, the incompatibilities between 0.7 and 0.5, and the fact that we’re very close to 1.0 (at which point all pre-1.0 releases will be unmaintained), 0.5 is now unmaintained. As with all of our previous releases, it will still be available for download on the old releases page.

As part of this process, METADATA is being frozen for 0.5. That means that if you want to tag a new version of your package or register a new package, the lowest version of Julia you can declare in your REQUIRE file is 0.6.0. If you haven’t updated your package to be compatible with 0.6, now is the time to do it.

Happy new year, everyone!


PackageEvaluator is back online
#2

Do you mean that 0.6 and 0.7 will be officially unmaintened same day as 1.0 will be released?


#3

No, we will continue to support 0.6 until the ecosystem has transitioned. However, we strongly encourage everyone to switch to 1.0 as soon as they can. 0.7 is a somewhat different story since there’s no reason to add new releases – it is intended only to smooth upgrading to 1.0. But we’ll see if 0.7 needs updates matching 1.0 or not.