Issues with PyPlot usage


I downloaded Version 0.5.2 of julia in windows(64 bit). When I added the PyPlot package, it had errors.I am unable to use the package.
Upon building the package, I received the following:

===========================================================================================[ ERROR: PyCall ]============================================================================================

LoadError: type Void has no field captures
while loading C:\Users\Uma\AppData\Roaming\SPB_Data\.julia\v0.5\PyCall\deps\build.jl, in expression starting on line 258


============================================================================================[ BUILD ERRORS] ]==========================================

WARNING: PyCall had build errors.

 - packages with build errors remain installed in C:\Users\Uma\AppData\Roaming\SPB_Data\.julia\v0.5
 - build the package(s) and all dependencies with `"PyCall")`
 - build a single package by running its `deps/build.jl` script


Any suggestions?


I just tested a clean PyPlot install with 0.5.2 on Win10/x64 (no other Python installed) and it worked fine. I would guess something wrong with the Python install – maybe from an existing install in your PATH. Try running"PyCall") and paste the output, in particular look for which Python it has selected (INFO: PyCall is using: ...).

By the way, if you are just starting out with Julia, use 0.6 instead! PyPlot / Win10 / 0.6 worked fine for me.

1 Like

It did not work on both versions of julia for me

It uses Conda package by default.