Issues with MethodOfLines in SciML tutorial

Hello everyone.

I used to use MethodeOfLines to learn and start using all the great work of Chris and all this wonderful community
But after running an update in the last 3 days
I can’t even run the example tutorial that can be found here

Here is the first error message

ERROR: MethodError: no method matching (SciMLBase.PDETimeSeriesSolution{Float64, 1, Dict{Num, Matrix{Float64}}, MethodOfLines.MOLMetadata{Val{true}(), MethodOfLines.DiscreteSpace{1, 1, MethodOfLines.CenterAlignedGrid}, MOLFiniteDifference{MethodOfLines.C

Yesterday I tried to solve this but without success
meanwhile I will try to download older julia version that was not updated and see if this error disappears
If one of you is familiar with such error message and guide me that will be great
Thank you

It’s unlikely that this has anything to do with your Julia version and likely that it is about the version of packages used. What’s the output of ]st in the environment you are running the code in?

I also get
ERROR: LoadError: MethodError: no method matching dlopen(::Nothing; throw_error=false)
recently when I try to update packages. I am using version julia 1.8.4.
Would also appreciate if someone knows how to solve such.

Hi Nils

Thank you,Yes for sur it is some thing like said

here is the output of ] st
(@v1.8) pkg> st
Status ~/.julia/environments/v1.8/Project.toml
⌅ [052768ef] CUDA v3.13.1
[a6be3551] CUDA_Driver v0.1.0
⌅ [5b8099bc] DomainSets v0.5.15
[94925ecb] MethodOfLines v0.8.4
[961ee093] ModelingToolkit v8.48.1
[1dea7af3] OrdinaryDiffEq v6.49.3
[94395366] ParallelStencil v0.6.1
[91a5bcdd] Plots v1.38.8
[4ee394cb] CUDA_Driver_jll v0.4.0+2
[76a88914] CUDA_Runtime_jll v0.4.0+1
Info Packages marked with ⌅ have new versions available but compatibility constraints restrict them from upgrading. To see why use status --outdated

and the output of ] status --outdated

(@v1.8) pkg> status --outdated
Status ~/.julia/environments/v1.8/Project.toml
⌅ [052768ef] CUDA v3.13.1 (<v4.0.1): ParallelStencil
⌅ [5b8099bc] DomainSets v0.5.15 (<v0.6.5): ModelingToolkit, Symbolics

yesterday I spent a lot of time installing new version or old versions of DomainSets, Symbolics,ModelingToolkit

I did this carefully but I had always the same Error

perhaps it is MethoeOfLines that is old now ?


Hi EuroXy

yes if we arrive to some thing about this error we will make some progress all together

Try using a new fresh environment.

Hi Imiq

That’s what I just did this way : I removed
rm .julia/environments/v1.8/Project.toml
rm .julia/environments/v1.8/Manifest.toml

So when I run the script of heat equation that I copied from the tutorial docs
julia ask me to repopulate the environment all what actually is needed
OrdinaryDiffEq, ModelingToolkit, MethodOfLines, DomainSets

But I have exactly the same error
ERROR: MethodError: no method matching (SciMLBase.PDETimeSeriesSolution…


I tested it here in 1.9+ series, and it worked. Also because this involves large packages, having that in a specific environment will make the usage of the packages much smoother. What I did is:

% mkdir naceur
% cd naceur
% juila

julia> activate .

naceur> add ... packages

julia> # ... run everything

ps: I did the same thing in 1.8.5 and it worked here, so I cannot help with the specific bug you are having, rather than suggesting a clean new environment as I did.

1 Like


Ok I’m doing this


Hi Imiq,

What you suggested worked for me, though to add to this I first had to do this:

pkg> generate demo
pkg> activate.
pkg> status

When I ran this new environment all issues seemed to be fixed

thank you @lmiq using new env does work

That should have been a transient error in CUDA-related packages, that had been resolved in a few hours, yesterday.

1 Like

Dear Imiq, EuRoXy, dan_tud, and giordano

I did exactly as Imiq and dan suggested to us, this helped me to have clean project populated only with the required packages to run MethodOfLines at the end I reinstalled CUDA from scratch when I saw giordano message
but I did not had any chance to have this error disappears :frowning:

I even removed 1.8.5 and installed again making sur that I removed also .julia/ directory
and gave a try with julia 1.9-rc
no change! the same error :face_exhaling:
I will continue tomorrow, may be I should run line by line or rewrite a small example
actually I used the tutorial example from the docs perhaps some thing is not good just in that script
but empirically I never have encountered such a behavior if some thing is not good in the script Julia often tell me where to look

Have A Nice Day

FWIW I just copied and pasted that script.

You may have an out to date access to some package server? It seems that should be something that will go away with the latest package versions once you get them

Yes I think
we will see in few days Imiq

I think MethodOfLines worked with 1.8.3 and I’m not so sure that this was also the case with 1.8.5 before I did the update of 1.8.5

See the update from Chris here, which is probably also your issue:

On a more general note I will reiterate what I said before though: it is exceedingly unlikely that and update from one patch version of Julia to another (i.e. incrementing the y in version 1.x.y) will break any of your workflow if you are using the same version of packages in both Julia versions. A patch update should only contain bugfixes so the only scenario where your workflow would change is if you happened to rely on a bug in a patch version that was fixed in the udpate.

Hi Nils

Yes! This have nothing to do with the update of Julia.
I went to see the discussion about MethodOfLines.
They are fixing the problem
Thanks a lot

1 Like

Shoud I modify the title of this question? I do not know how ?

Changed it for you.

Great !