Issue plotting from REPL

Hi,

I’m facing a problem trying to plot from the REPL (that was working fine but for some reason has decided to stop doing so).

If I run this simple code:

julia> using Plots
julia> gr()
julia> x = Vector(1:pi/10:6*pi);
julia> y = cos.(x);
julia> plot(x, y)

The REPL will not return from the last sentence. However, the same does not occur running the same code in the jupyter-notebook in which the plot shows as expected.

Any hint ?

Gaston

Have you tried updating your packages?

Also note that GR has been the default plotting package for a while, so gr() is no longer necessary.

Thanks for the response.

I’ve just tried updating: no luck.

Regarding the backend, using different backends leads different result: plotly calls the browser while pyplot behaves normally throwing just a standard plot window.

… is your run-time really up-to-date? Please stop any GKSTerm or (GKS QtTerm) and:

ENV["GRDIR"]=""
] update GR

If this doesn’t help, which platform are you using?

Still no luck.

julia> versioninfo()
Julia Version 1.4.1
Commit 381693d3df (2020-04-14 17:20 UTC)
Platform Info:
OS: Linux (x86_64-linux-gnu)
CPU: Intel® Core™ i5-3210M CPU @ 2.50GHz
WORD_SIZE: 64
LIBM: libopenlibm
LLVM: libLLVM-8.0.1 (ORCJIT, ivybridge)
julia> ENV[“GRDIR”]=""

(@v1.4) pkg> update GR
Updating registry at ~/.julia/registries/General
Updating git-repo https://github.com/JuliaRegistries/General.git
Updating ~/.julia/environments/v1.4/Project.toml
[no changes]
Updating ~/.julia/environments/v1.4/Manifest.toml
[no changes]

Sorry - my mistake:

ENV["GRDIR"]=""
] build GR

and then

using GR
version()

… should respond with “0.49.0.post45”

Ok, I get:

julia> ENV[“GRDIR”]=""
“”

(@v1.4) pkg> build GR
Building GR → ~/.julia/packages/GR/cRdXQ/deps/build.log

julia> using GR

julia> version()
“0.49.0.post47”

Hi,

The issue seems to be solved after installing qt5-default.

The problem may have arisen after and upgrade in Debian testing. Not sure… the only related package that I see was install on 2020-05-07 is libqt5scripttools5.

Anyway, after installing qt5-default the plots are working normally using GR backend.

regards,

Gaston