Can't show plot in windows 10 from REPL

Hi everyone! I can’t seem to get plots to show from julia REPL on windows 10 for some reason. Say I type the following to julia REPL:

using Plots  # I am using the default GR backend
p = plot(rand(5))  # No output
gui(p) # No output either

I am using Julia 1.7.2. What am I doing wrong?

Hard to say without any error messages.

You might have problem with the GR backend. Try out the advice on this page.

Maybe ElectronDisplay.jl?

Thanks for the help!

I tried the debug steps for GR, but didn’t find anything. This is what the log shows (after trying to install the binary of GR directly).

┌ Info: Emptying depsfile. GR provider is GR
│   provider = "GR"
└   depsfile = "C:\\Users\\my_user_name\\.julia\\packages\\GR\\KPElO\\deps\\deps.jl"
[ Info: Downloading pre-compiled GR latest Windows binary

BTW, Plots and GR seems to work fine in Jupyter notebooks, which makes this really confusing.

ElectronDisplay worked beautifully! I will use this for now.

Could you show your actual Julia REPL usage?

I decided to delete my .julia folder and install only Plots to check. The plots showed up without a problem! Probably my global environment had some weird conflict from installing and uninstalling many packages.

Thanks everyone for the help! I should certainly learn to keep my global environment clean in the future.