Issue by plotting on a MacOS


I have just installed Julia 1.7, and Julia.jl + Jupyter on two MacBook (similar hardware and same MacOS) to attend a workshop by using the install.jl script that you can find for example here:

The installation seems OK. No error messages or warnings.

On the first laptop I had no problems to run a test script. On the second one, it seems that I cannot plot. Boiling down the issue, if I run:

using Plots

after few seconds on Jupiter the julia kernel restarts, while if I run it directly in the REPL shell I got the error:

signal (6): Abort trap: 6
in expression starting at none:0
__pthread_kill at /usr/lib/system/libsystem_kernel.dylib (unknown line)
Allocations: 18302486 (Pool: 18296275; Big: 6211); GC: 20

I suppose that the problem is not in the installation itself because on the other laptop plotting is not a problem, but it should be related to something “around". However, I do not know how to trace back where can be the issue. Somebody can give me some hints?

The issue is not related to plot. I built GR:

]build GR

**Building** GR → `~/.julia/scratchspaces/44cfe95a-1eb2-52ea-b672-e2afdf69b78f/9f836fb62492f4b0f0d3b06f55983f2704ed0883/build.log`
**Precompiling** project...
2 dependencies successfully precompiled in 40 seconds (133 already precompiled)

and then used to plot an histogram but got the same problem:

> using GR
> histogram(randn(10000))

signal (6): Abort trap: 6
in expression starting at REPL[5]:1
__pthread_kill at /usr/lib/system/libsystem_kernel.dylib (unknown line)
Allocations: 20274905 (Pool: 20266480; Big: 8425); GC: 25

Some additional info:

> versioninfo()
Julia Version 1.7.2
Commit bf53498635 (2022-02-06 15:21 UTC)
Platform Info:
OS: macOS (x86_64-apple-darwin19.5.0)
CPU: Intel(R) Core(TM) i5-7287U CPU @ 3.30GHz
LIBM: libopenlibm
LLVM: libLLVM-12.0.1 (ORCJIT, skylake)

All the best,