Is anyone using Emacs on Windows 10?


#1

If so, would you have some advice on which Emacs to choose and how to set up the environment?


#2

I use emacs on Windows 10 with Julia mode. It works pretty well; the only annoyance is that the auto-indent feature loses track of the indent level in long functions (a long-standing known issue in Julia-mode). On my laptop I use emacs 24.3.1; on my desktop I have a newer version, and both work.


#3

Have you tried this:

  • menu:Options
  • customize-emacs
  • Programming
    • languages
      • Julia
        • Julia Max Block Lookback

20000 is usually good for me (and I write some distressingly long functions).

Now if I could only configure the Discourse composer to use emacs shortcuts … Are there really that many people so desperate to waste paper that they need to hijack ctrl-P?


#4

OK, yes, this fixed the problem in the MWE that I saved (122-line function). Thanks for the suggestion!

I’m a bit confused though-- this is an 19-month-old issue for Julia emacs mode, and it is still open:

https://github.com/JuliaEditorSupport/julia-emacs/issues/5

Would the problem be fixed for almost everyone if the default was just changed from 5000 to 20000, and then someone should close the issue?


#5

Thanks for this! I was having this problem with Julia mode (on Linux).

For us old skool emacs users:

(setq julia-max-block-lookback 20000)


#6

I use this Emacs with Windows 10, https://sourceforge.net/projects/emacsbinw64, though I don’t use it for Julia so I can’t comment on setting things up there.