Installing QML.jl


#1

@jtravs To my surprise, the new test binaries to prepare for the release worked on my wife’s PC (win10, 64 bit Julia 0.5), following the Readme:

Pkg.clone("https://github.com/barche/QML.jl.git")
Pkg.build("QML")
Pkg.test("QML")

Feel free to test, apart from the GLVisualize example everything should be as in the planned release. A good place to start is example/gui.jl


Julia for GUI app
#2

When I try to update (I even removed it to try again). Don’t understand the complain.

julia> Pkg.clone("https://github.com/barche/QML.jl.git")
INFO: Cloning QML from https://github.com/barche/QML.jl.git
INFO: Computing changes...
ERROR: fixed packages introduce conflicting requirements for CxxWrap:
         QML requires versions [0.1.8,∞) [none of the available versions can satisfy this requirement]
       available versions are 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 0.1.6 and 0.1.7
 in check_requirements(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Available}}, ::Dict{String,Base.Pkg.Types.Fixed}) at .\pkg\query.jl:191

#3

Did you run Pkg.update() first? It requires a CxxWrap from 2 days ago.


#4

Yes, ofc. I even removed/reinstalled it.


#5

@barche Excellent. It now works as you say, and has perfect HiDPI rendering. Very happy indeed. Thanks for getting this up and running!


#6

Unfortunately the packaging system is still very fragile. One problem somewhere propagates to a point where I fear the only solution it nuke all and start over. GLVisualize doesn’t want to work now either. And when I try to remove it … it installs its dependencies.

julia> Pkg.rm("GLVisualize")
INFO: Cloning cache of GLAbstraction from https://github.com/JuliaGL/GLAbstraction.jl.git
INFO: Cloning cache of GLFW from https://github.com/JuliaGL/GLFW.jl.git
INFO: Cloning cache of GLWindow from https://github.com/JuliaGL/GLWindow.jl.git
INFO: Installing GLAbstraction v0.1.0
INFO: Installing GLFW v1.2.0
INFO: Installing GLWindow v0.1.4
INFO: Building GLFW

#7

Hmm, it seems your package metadata is somehow out of sync or out of date, CxxWrap 0.1.8 is definitely in there:


#8

To nuke it and start over, just copy the REQUIRE file from .julia/v0.5 somewhere else, remove .julia, put back the REQUIRE file, and do Pkg.update(). This will re-install the same packages.

This is actually something I recommend to do from time to time!


#9

Yes, but it would be better not having to do it. And for that it would help if Pkg.rm() REALLY removed the package instead of hiding it under .trash & .cache