Installing julia v1.6.2 behind proxy

I am trying to install Julia on a linux box which is behind proxy. The installation of julia is quite easy, but the installation of modules is very exhausting.

  1. I tried setting up https_proxy - Failed
    • sslVerify: false on git level - Failed
    • JULIA_SSL_NO_VERIFY and other variables like these - Failed.
    • .curlrc file with insecure in it - Failed.
    • searched for documentations about the libgit2 and not really helpful documents are available for this on the official page or on the internet.

julia> versioninfo()
Julia Version 1.6.2
Platform Info:
OS: Linux (x86_64-pc-linux-gnu)
LIBM: libopenlibm
LLVM: libLLVM-11.0.1 (ORCJIT, haswell)
JULIA_DEPOT_PATH = /opt/soft/julia/v1.6.2/julia_home:~/.julia

1st Error Message:

Error: (v1.6) pkg> add IJulia
Installing known registries into `~/.julia`
┌ Warning: could not download
└ @ Pkg.Types // /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.6/Pkg/src/Types.jl:997
┌ Warning: could not download //
└ @ Pkg.Types /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.6/Pkg/src/Types.jl:997
Cloning registry from "//" ERROR: failed to clone from //, error: GitError(Code:ERROR, Class:SSL, SSL error: 0xffff8e00 - SSL - An invalid SSL record was received)

2nd Error Message:

Changed the https_proxy to http:// from https://

Cloning registry from "[](//" ERROR: failed to clone from [](//, error: GitError(Code:ERROR, Class:SSL, SSL error: 0xffffda9e - X509 - The extensi on tag or value is invalid : ASN1 - ASN1 tag was of an unexpected value)

I cannot proceed further with Julia because of this error on linux box. Please help me on this.

Have you tried Julia 1.7 ? Does command line git work for you on external repos?
Please have look at this thread

I have tried beta version of the software and it works fine with the SSL. And the environmental variable worked as you said. But I am having dependency downloading problems now for IJulia.

(v1.7) pkg> add IJulia                                                        
  Downloaded artifact: ZeroMQ                                                 
ERROR: Unable to automatically install 'ZeroMQ' from '/opt/soft/cdtng/tools/ju

Thanks John for the help.

Also the stable release v.1.6.2 is not actually very stable for linux (redhat). I could not overcome the SSL error for installing the packages. Is there any environment variable that could do the same as “JULIA_PKG_USE_CLI_GIT” for v1.7.0 . If not is there way we could set this for the SSL or disable the SSL on libgit2 level. Can someone please help me out here?

We could not just proceed with the beta version as well.

@vijaysrini08 Whoa… let us go slow here. Firstly it looks like you are using distribution supplied RPM to install Julia. Can you confirm how you are installing Julia?

I install Julia on Fedora Linux by donwloading the tarball.
Then as a sudo user I unpack this in /usr/local
ln -s /usr/local/julia-1.7.0 julia
(or whatever version you want to use)
In my .bashrc
export PATH=/usr/local/julia/bin:$PATH

Yes I KNOW I should be using software modules. Mea culpa