how to make julia install a curl that respects the proxy?


#1

I’m building Julia 1.0.3 (and probably 0.7.0) for deployment on a KNL cluster which sits behind a proxy. Cross-compilation succeeds and julia repl runs, as long as there is no need to load dependencies (e.g. MPI) at run-time. We are able to run git and curl from command line on these systems, but julia appears to be installing it’s own versions of these, and they are unable to navigate the proxy; support is explicitly disabled in curl. The error returned in the repl is:

(v1.0) pkg> add MPI
   Cloning default registries into /home/willmore/.julia/registries
   Cloning registry General from "https://github.com/JuliaRegistries/General.git"
ERROR: failed to clone from https://github.com/JuliaRegistries/General.git, error: GitError(Code:ERROR, Class:Net, curl error: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
)

Is there a way to configure julia installation so that it will build a curl which respects the proxy?


#2

Installing a package here is not using curl, it is using git clone. To tell git to use a proxy, you need to update your .gitconfig settings as described e.g. here or here.


#3

A-ha!

Git was able to recognize and use HTTPS_PROXY environment variable when running from command line, but needed this info set in .gitconfig when invoked by the repl.

[https]
	proxy = https://proxy:3128

That fixed it, thank you for your kind assist.