Installation Issues for TidierDB with Tidier

I’m pretty new to using Julia and was trying to test out the Tidier packages and add in the TidierDB. However, when I try to add the TidierDB package after already having Tidier installed I get a requirements issue. It looks like it has to do with the Chain package being v0.5.0 for Tidier while it looks like TidierDB requires v0.6.0. I can remove Tidier and add TidierDB no issues. I can remove all Tidier packages and just add TidierData no issues. It’s just when I try to add both Tidier (or TidierData) AND TidierDB that the version issue has a problem. Does anyone know how to get around this or is this a bug the devs have to fix?

(@v1.10) pkg> add TidierDB
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package Tidier [f0413319]:
Tidier [f0413319] log:
├─possible versions are: 0.3.0-1.3.0 or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions: 0.3.0-1.3.0
├─restricted by compatibility requirements with Chain [8be319e6] to versions: 1.0.0-1.3.0 or uninstalled, leaving only versions: 1.0.0-1.3.0
│ └─Chain [8be319e6] log:
│ ├─possible versions are: 0.1.0-0.6.0 or uninstalled
│ ├─restricted to versions * by an explicit requirement, leaving only versions: 0.1.0-0.6.0
│ └─restricted by compatibility requirements with TidierDB [86993f9b] to versions: 0.6.0
│ └─TidierDB [86993f9b] log:
│ ├─possible versions are: 0.1.0-0.1.1 or uninstalled
│ └─restricted to versions * by an explicit requirement, leaving only versions: 0.1.0-0.1.1
└─restricted by compatibility requirements with TidierData [fe2206b3] to versions: 0.3.0-0.7.7 or uninstalled — no versions left
└─TidierData [fe2206b3] log:
├─possible versions are: 0.8.0-0.15.1 or uninstalled
└─restricted by compatibility requirements with Chain [8be319e6] to versions: uninstalled
└─Chain [8be319e6] log: see above

1 Like

One for @kdpsingh, looks like Tidier and TidierDB have some compat issue?

1 Like

Thanks for tagging me - happy to help.

Can you do import Pkg; Pkg.status() and share the output?

I suspect the issue is that Tidier may need to be updated because one of the subpackages was out of sync in terms of Julia version dependencies.

TidierDB.jl has not yet been added to Tidier.jl yet, so I haven’t had the chance to ensure the dependencies are consistent, but I think with the latest version of Tidier.jl that they are.

In any case, I’m planning to cut a new release of Tidier.jl that includes both TidierDB.jl and TidierFiles.jl (which just arrived on the Julia registry last night).


From the output you shared, I see the issue though regarding Chain versions being out of sync. In packaging the new version of Tidier, we will get this corrected. Thank you for bringing it our attention :smiley:


Here’s the status you asked for:

[cbdf2221] AlgebraOfGraphics v0.6.18
[69666777] Arrow v2.7.1
[336ed68f] CSV v0.10.14
[13f3f980] CairoMakie v0.11.10
[8be319e6] Chain v0.6.0
⌃ [1b08a953] Dash v1.1.2
[a93c6f00] DataFrames v1.6.1
[55939f99] DecFP v1.3.2
[634d3b9d] DrWatson v2.15.0
[d2f5444f] DuckDB v0.10.1
[8f5d6c58] EzXML v1.2.0
[fb4d412d] FixedPointDecimals v0.5.2
[7073ff75] IJulia v1.24.2
[e6f89c97] LoggingExtras v1.0.3
[ee78f7c6] Makie v0.20.9
[e1d29d7a] Missings v1.2.0
[6741aa20] Neptune v0.14.0
[be6f12e9] ODBC v1.1.2
[bac558e1] OrderedCollections v1.6.3
[8b842266] PalmerPenguins v0.1.4
[f0f68f2c] PlotlyJS v0.18.13
[91a5bcdd] Plots v1.40.4
⌃ [c3e4b0f8] Pluto v0.14.7
[7f904dfe] PlutoUI v0.7.58
[438e738f] PyCall v1.96.4
[bd369af6] Tables v1.11.1
[86993f9b] TidierDB v0.1.1
[856ac37a] UrlDownload v1.0.1
[72c71f33] XML v0.3.2
[331672ed] XlsxWriter v0.1.0
[cf7118a7] UUIDs
Info Packages marked with ⌃ have new versions available and may be upgradable.

1 Like

Thanks again for reporting this issue. This is now fixed in the latest update to TidierData (to fix the compatibility issue with Chain).

Tidier.jl v1.4.0 now includes TidierDB and TidierFiles - on its way to the registry now.

1 Like

Thanks. I tried updating the Tidier package but it wouldn’t change from 0.7 for some reason. I tried removing Tidier and re-adding it and it installed 0.7 again though it showed Tidier is supposed to have an update available. Attempting to update again didn’t make any change. However, I added TidierData and TidierDB and that forced the update of Tidier to 1.4. I’m going to be playing around with it today.


1 Like