Can't install juliadb

I’m not sure what my options are here. Thoughts/recommendations?

(@v1.5) pkg> add JuliaDB
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package Plots [91a5bcdd]:
Plots [91a5bcdd] log:
├─possible versions are: [0.12.1-0.12.4, 0.13.0-0.13.1, 0.14.0-0.14.2, 0.15.0-0.15.1, 0.16.0, 0.17.0-0.17.4, 0.18.0, 0.19.0-0.19.3, 0.20.0-0.20.6, 0.21.0, 0.22.0-0.22.5, 0.23.0-0.23.2, 0.24.0, 0.25.0-0.25.3, 0.26.0-0.26.3, 0.27.0-0.27.1, 0.28.0-0.28.4, 0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6] or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions [0.12.1-0.12.4, 0.13.0-0.13.1, 0.14.0-0.14.2, 0.15.0-0.15.1, 0.16.0, 0.17.0-0.17.4, 0.18.0, 0.19.0-0.19.3, 0.20.0-0.20.6, 0.21.0, 0.22.0-0.22.5, 0.23.0-0.23.2, 0.24.0, 0.25.0-0.25.3, 0.26.0-0.26.3, 0.27.0-0.27.1, 0.28.0-0.28.4, 0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6]
├─restricted by compatibility requirements with StaticArrays [90137ffa] to versions: [0.21.0, 0.22.0-0.22.5, 0.23.0-0.23.2, 0.24.0, 0.25.0-0.25.3, 0.26.0-0.26.3, 0.27.0-0.27.1, 0.28.0-0.28.4, 0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6] or uninstalled, leaving only versions: [0.21.0, 0.22.0-0.22.5, 0.23.0-0.23.2, 0.24.0, 0.25.0-0.25.3, 0.26.0-0.26.3, 0.27.0-0.27.1, 0.28.0-0.28.4, 0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6]
│ └─StaticArrays [90137ffa] log:
│ ├─possible versions are: [0.8.0-0.8.3, 0.9.0-0.9.2, 0.10.0, 0.10.2-0.10.3, 0.11.0-0.11.1, 0.12.0-0.12.5, 1.0.0-1.0.1] or uninstalled
│ ├─restricted by compatibility requirements with KernelAbstractions [63c18a36] to versions: [0.12.0-0.12.5, 1.0.0-1.0.1]
│ │ └─KernelAbstractions [63c18a36] log:
│ │ ├─possible versions are: [0.1.0-0.1.6, 0.2.0-0.2.6, 0.3.0-0.3.3, 0.4.0-0.4.6, 0.5.0-0.5.3] or uninstalled
│ │ ├─restricted to versions * by an explicit requirement, leaving only versions [0.1.0-0.1.6, 0.2.0-0.2.6, 0.3.0-0.3.3, 0.4.0-0.4.6, 0.5.0-0.5.3]
│ │ └─restricted by compatibility requirements with Adapt [79e6a3ab] to versions: [0.3.0-0.3.3, 0.4.0-0.4.6, 0.5.0-0.5.3] or uninstalled, leaving only versions: [0.3.0-0.3.3, 0.4.0-0.4.6, 0.5.0-0.5.3]
│ │ └─Adapt [79e6a3ab] log:
│ │ ├─possible versions are: [0.3.0-0.3.1, 0.4.0-0.4.2, 1.0.0-1.0.1, 1.1.0, 2.0.0-2.0.2, 2.1.0, 2.2.0, 2.3.0, 2.4.0, 3.0.0, 3.1.0-3.1.1, 3.2.0] or uninstalled
│ │ └─restricted by compatibility requirements with CUDA [052768ef] to versions: [2.0.0-2.0.2, 2.1.0, 2.2.0, 2.3.0, 2.4.0, 3.0.0, 3.1.0-3.1.1, 3.2.0]
│ │ └─CUDA [052768ef] log:
│ │ ├─possible versions are: [0.1.0, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0-1.3.3, 2.0.0-2.0.2, 2.1.0, 2.2.0-2.2.1, 2.3.0, 2.4.0-2.4.1, 2.5.0, 2.6.0-2.6.1] or uninstalled
│ │ ├─restricted to versions * by an explicit requirement, leaving only versions [0.1.0, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0-1.3.3, 2.0.0-2.0.2, 2.1.0, 2.2.0-2.2.1, 2.3.0, 2.4.0-2.4.1, 2.5.0, 2.6.0-2.6.1]
│ │ └─restricted by julia compatibility requirements to versions: [1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0-1.3.3, 2.0.0-2.0.2, 2.1.0, 2.2.0-2.2.1, 2.3.0, 2.4.0-2.4.1] or uninstalled, leaving only versions: [1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0-1.3.3, 2.0.0-2.0.2, 2.1.0, 2.2.0-2.2.1, 2.3.0, 2.4.0-2.4.1]
│ └─restricted by compatibility requirements with Images [916415d5] to versions: [0.8.0-0.8.3, 0.9.0-0.9.2, 0.10.0, 0.10.2-0.10.3, 0.11.0-0.11.1, 0.12.0-0.12.5], leaving only versions: 0.12.0-0.12.5
│ └─Images [916415d5] log:
│ ├─possible versions are: [0.17.3, 0.18.0, 0.19.0-0.19.3, 0.20.0-0.20.2, 0.21.0-0.21.1, 0.22.0-0.22.5, 0.23.0-0.23.3] or uninstalled
│ └─restricted by compatibility requirements with PlotShapefiles [297584a0] to versions: 0.22.0-0.22.5
│ └─PlotShapefiles [297584a0] log:
│ ├─possible versions are: [0.1.0, 0.2.0, 0.2.2] or uninstalled
│ └─restricted to versions * by an explicit requirement, leaving only versions [0.1.0, 0.2.0, 0.2.2]
├─restricted by compatibility requirements with FixedPointNumbers [53c48c17] to versions: [0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6] or uninstalled, leaving only versions: [0.29.0-0.29.9, 1.0.0-1.0.14, 1.1.0-1.1.4, 1.2.0-1.2.6, 1.3.0-1.3.7, 1.4.0-1.4.4, 1.5.0-1.5.9, 1.6.0-1.6.12, 1.7.0-1.7.3, 1.8.0-1.8.1, 1.9.0-1.9.1, 1.10.0-1.10.6]
│ └─FixedPointNumbers [53c48c17] log:
│ ├─possible versions are: [0.5.0-0.5.3, 0.6.0-0.6.1, 0.7.0-0.7.1, 0.8.0-0.8.4] or uninstalled
│ └─restricted by compatibility requirements with PlotShapefiles [297584a0] to versions: [0.7.1, 0.8.0-0.8.4]
│ └─PlotShapefiles [297584a0] log: see above
└─restricted by compatibility requirements with RecipesBase [3cdcf5f2] to versions: [0.12.1-0.12.4, 0.13.0-0.13.1, 0.14.0-0.14.2, 0.15.0-0.15.1, 0.16.0, 0.17.0-0.17.4, 0.18.0, 0.19.0-0.19.3, 0.20.0-0.20.6, 0.21.0, 0.22.0-0.22.5, 0.23.0-0.23.2, 0.24.0, 0.25.0-0.25.3, 0.26.0-0.26.3, 0.27.0-0.27.1, 0.28.0-0.28.4] or uninstalled — no versions left
└─RecipesBase [3cdcf5f2] log:
├─possible versions are: [0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 1.0.0-1.0.2, 1.1.0-1.1.1] or uninstalled
├─restricted by compatibility requirements with GeoInterface [cf35fbd7] to versions: [0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 1.0.0-1.0.2, 1.1.0-1.1.1]
│ └─GeoInterface [cf35fbd7] log:
│ ├─possible versions are: [0.4.0-0.4.1, 0.5.0-0.5.4] or uninstalled
│ └─restricted to versions * by an explicit requirement, leaving only versions [0.4.0-0.4.1, 0.5.0-0.5.4]
└─restricted by compatibility requirements with JuliaDB [a93385a2] to versions: [0.4.0, 0.5.0, 0.6.0, 0.7.0]
└─JuliaDB [a93385a2] log:
├─possible versions are: [0.9.0, 0.10.0, 0.11.0-0.11.2, 0.12.0, 0.13.0-0.13.1] or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions [0.9.0, 0.10.0, 0.11.0-0.11.2, 0.12.0, 0.13.0-0.13.1]
└─restricted by compatibility requirements with WeakRefStrings [ea10d353] to versions: 0.13.0-0.13.1 or uninstalled, leaving only versions: 0.13.0-0.13.1
└─WeakRefStrings [ea10d353] log:
├─possible versions are: [0.5.1-0.5.8, 0.6.0-0.6.2] or uninstalled
├─restricted by compatibility requirements with JuliaDB [a93385a2] to versions: [0.5.1-0.5.8, 0.6.0-0.6.2]
│ └─JuliaDB [a93385a2] log: see above
└─restricted by compatibility requirements with DBFTables [75c7ada1] to versions: 0.6.0-0.6.2
└─DBFTables [75c7ada1] log:
├─possible versions are: [0.1.0-0.1.1, 0.2.0-0.2.2] or uninstalled
└─restricted by compatibility requirements with Shapefile [8e980c4a] to versions: 0.2.0-0.2.2
└─Shapefile [8e980c4a] log:
├─possible versions are: [0.4.0, 0.5.0, 0.6.0-0.6.3, 0.7.0] or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions [0.4.0, 0.5.0, 0.6.0-0.6.3, 0.7.0]
├─restricted by compatibility requirements with PlotShapefiles [297584a0] to versions: 0.6.2-0.6.3
│ └─PlotShapefiles [297584a0] log: see above
└─restricted by compatibility requirements with RecipesBase [3cdcf5f2] to versions: [0.4.0, 0.5.0, 0.6.0-0.6.2] or uninstalled, leaving only versions: 0.6.2
└─RecipesBase [3cdcf5f2] log: see above

See Issue with updating plots · Issue #374 · JuliaData/JuliaDB.jl · GitHub perhaps? Looks like some maintenance is required…

1 Like

Thanks. Ugh.