ImageView on JuliaPro 0.6 fails to build

juliapro

#1

I installed JuliaPro 0.6 on a Mac and when I tried to build the ImageView package it failed.

The error was in the Gtk package:

LoadError: SystemError: opening file /Applications/JuliaPro-0.6.0.1.app/Contents/Resources/pkgs-0.6.0.1/v0.6/Homebrew/deps/usr/Library/Taps/homebrew/homebrew-core/Formula/gnome-icon-theme.rb: No such file or directory while loading /Applications/JuliaPro-0.6.0.1.app/Contents/Resources/pkgs-0.6.0.1/v0.6/Gtk/deps/build.jl, in expression starting on line 59

The original change was in the homebrew package - in an older version this file “gnome-icon-theme.rb” does exist.

Any help how to manage it is most appreciated.


#2

I could only fix this problem by adding the following symlink:

/usr/local/lib/julia/v0.6/Homebrew/deps/usr/Library/Taps/homebrew/homebrew-core/Aliases/gnome-icon-theme => …/Formula/gnome-recipes.rb

I think, there’s also a PR for this problem, but it has been rejected.


#3

Thanks Josef, but no go.

When I added your line in gnome-icon-theme.rb in the “bottle do” loop (is that the correct place?)
and I tried to build, the file was overwritten by the version from the git.
Same case when I just added the missing file (gnome-icon-theme.rb) to the directory where it is missing from - upon building it was deleted (I assume it takes the latest from git?).

How do you prevent it from deleting the changes?

Thanks a lot,
Alex