Pkg build fails needing to load dependencies

I’m new to Julia, only one week experience. Tried to install the Gtk.jl package, but when I run build it finds missing dependencies, prompts for the admin password, lists the items it needs, but aborts at the system prompt. Eventually, I tried installing the depencies outside julia - no problem, then re-ran and all is now well.

I’m running Linux Mint 18 here.

Is this a known problem?

It’s really hard to say without more detail. Do you have any record of what the error messages were?

1 Like

Here’s the output from the failed attempt:

(v1.0) pkg> build Gtk
Building LibCURL ─→ ~/.julia/packages/LibCURL/Z32eb/deps/build.log
Building WinRPM ──→ ~/.julia/packages/WinRPM/GxewC/deps/build.log
Building Homebrew → ~/.julia/packages/Homebrew/l8kUw/deps/build.log
Building Cairo ───→ ~/.julia/packages/Cairo/mbKYP/deps/build.log
Building Gtk ─────→ ~/.julia/packages/Gtk/b18rN/deps/build.log
[sudo] password for bill:
┌ Error: Error building Gtk:
│ Reading package lists…
│ Building dependency tree…
│ Reading state information…
│ The following packages were automatically installed and are no longer required:
│ linux-image-4.4.0-116-lowlatency linux-tools-4.4.0-127
│ linux-tools-4.4.0-127-lowlatency
│ Use ‘sudo apt autoremove’ to remove them.
│ The following additional packages will be installed:
│ libatk-bridge2.0-dev libatspi2.0-dev libepoxy-dev libgmp-dev libgmpxx4ldbl
│ libxtst-dev nettle-dev x11proto-record-dev
│ Suggested packages:
│ gmp-doc libgmp10-doc libmpfr-dev libgtk-3-doc
│ The following NEW packages will be installed
│ libatk-bridge2.0-dev libatspi2.0-dev libepoxy-dev libgmp-dev libgmpxx4ldbl
│ libgtk-3-dev libxtst-dev nettle-dev x11proto-record-dev
│ 0 to upgrade, 9 to newly install, 0 to remove and 47 not to upgrade.
│ Need to get 2355 kB of archives.
│ After this operation, 17.3 MB of additional disk space will be used.
│ Do you want to continue? [Y/n] Abort.
│ ERROR: LoadError: failed process: Process(sudo apt-get install libgtk-3-dev, ProcessExited(1)) [1]
│ Stacktrace:
│ [1] error(::String, ::Base.Process, ::String, ::Int64, ::String) at ./error.jl:42
│ [2] pipeline_error at ./process.jl:695 [inlined]
│ [3] £run£505(::Bool, ::Function, ::Cmd) at ./process.jl:653
│ [4] run(::Cmd) at ./process.jl:651
│ [5] macro expansion at ./logging.jl:308 [inlined]
│ [6] run(::BinDeps.SynchronousStepCollection) at /home/bill/.julia/packages/BinDeps/ZEval/src/BinDeps.jl:518
│ [7] satisfy!(::BinDeps.LibraryDependency, ::Array{DataType,1}) at /home/bill/.julia/packages/BinDeps/ZEval/src/dependencies.jl:944
│ [8] satisfy!(::BinDeps.LibraryGroup, ::Array{DataType,1}) at /home/bill/.julia/packages/BinDeps/ZEval/src/dependencies.jl:910
│ [9] satisfy!(::BinDeps.LibraryGroup) at /home/bill/.julia/packages/BinDeps/ZEval/src/dependencies.jl:874
│ [10] top-level scope at /home/bill/.julia/packages/BinDeps/ZEval/src/dependencies.jl:977
│ [11] include at ./boot.jl:317 [inlined]
│ [12] include_relative(::Module, ::String) at ./loading.jl:1038
│ [13] include(::Module, ::String) at ./sysimg.jl:29
│ [14] include(::String) at ./client.jl:388
│ [15] top-level scope at none:0
│ in expression starting at /home/bill/.julia/packages/Gtk/b18rN/deps/build.jl:63

When it prompts with
│ Do you want to continue? [Y/n] Abort
I would normally hit return to continue, but as this was being run under julia there
was no opportunity to respond. I presume it just got a null or invalid input and gave up.