I'm having trouble installing GPLK

I’m fairly new to Julia, I’m trying to install GPLK package but this erroe keeps showing up:

(@v1.6) pkg> add GPLK
Updating registry at C:\Users\doriiido\.julia\registries\General
Updating git-repo https://github.com/JuliaRegistries/General.git
ERROR: The following package names could not be resolved:

  • GPLK (not found in project, manifest or registry)

[1] pkgerror(msg::String)
@ Pkg.Types C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\Types.jl:55
[2] ensure_resolved(ctx::Pkg.Types.Context, pkgs::Vector{Pkg.Types.PackageSpec}; registry::Bool)
@ Pkg.Types C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\Types.jl:883
[3] add(ctx::Pkg.Types.Context, pkgs::Vector{Pkg.Types.PackageSpec}; preserve::Pkg.Types.PreserveLevel, platform::Base.BinaryPlatforms.Platform, kwargs::Base.Iterators.Pairs{Symbol, Base.TTY, Tuple{Symbol}, NamedTuple{(:io,), Tuple{Base.TTY}}})
@ Pkg.API C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:193
[4] add(pkgs::Vector{Pkg.Types.PackageSpec}; io::Base.TTY, kwargs::Base.Iterators.Pairs{Union{}, Union{}, Tuple{}, NamedTuple{(), Tuple{}}})
@ Pkg.API C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:80
[5] add(pkgs::Vector{Pkg.Types.PackageSpec})
@ Pkg.API C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:78
[6] #add#23
@ C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:76 [inlined]
[7] add
@ C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:76 [inlined]
[8] #add#22
@ C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:75 [inlined]
[9] add(pkg::String)
@ Pkg.API C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\API.jl:75
[10] top-level scope
@ Untitled-1:2

Can anyone help me with this? I’m having the same issues ot install cbc or CPLEX

It’s not “GPLK”, it’s “GLPK” (GLPK.jl).


Also is there a particular reason you are using Julia 1.6?

1 Like

I’m not sure. I just downloaded Julia and installed for an optimization course I’m doing. What should I be using instead?

Thanks, I tried this just now but I got the following:

ERROR: UndefVarError: GPLK not defined
[1] top-level scope
@ Untitled-1:2

This is what I entered:


I also tried Pkg.add(“GPLK”) as the documentation stated.

And I tried:

(@v1.6) pkg> add “GPLK”(GPLK.jl)
ERROR: Unable to parse (GPLK.jl) as a package.

(@v1.6) pkg> add “GPLK”
ERROR: The following package names could not be resolved:

  • GPLK (not found in project, manifest or registry)

Its GLPK. Note the L before the P.

And Julia 1.6 is fine to use.

1 Like

apologies, I did not notice the misspelling

Thank you kindly

1 Like