IJulia in 1.7 fails on Mac M1: Solved!

All fixed. Read @giordano’s post and my last one.

Just installed 1.7 on M1 mac. Started from scratch with no .julia directory.

Tried to fire up a notebook and got this

julia> notebook(;dir=pwd())
install Jupyter via Conda, y/n? [y]: y
[ Info: Downloading miniconda installer ...
ERROR: Unsupported miniconda platform: MacOSX-arm64

What should I do?

Try reading the documentation of Conda.jl

Using Miniforge

Miniforge is a community based conda installer by conda-forge, a part of NumFOCUS.
Using miniforge and conda-forge in general avoids using repo.anaconda.com
maintained by Anaconda, Inc which has terms of conditions that you may want to avoid.
conda-forge packages are hosted on anaconda.org, but Anaconda, Inc has been
providing hosting for free under the terms of conda-forge which is BSD-3-Clause
on top of the original license of the software packages. To use miniforge, use
the CONDA_JL_USE_MINIFORGE environment variable.


pkg> build Conda

Also note that you have to use Miniforge for aarch64-linux-gnu and
aarch64-apple-darwin platforms as Miniconda is not available for those platforms yet.

This is actually the default in the master branch of Conda.jl, but it didn’t make it to a release yet



I use conda only with notebooks and have no clue about fixing problems like the one I have.

I tried to understand your respose as best I could and (1) typed your two lines, (2) restarted Julia, (3) typed them again, and (4) restarted julia.

notebook started up, I got to my notebook, and then

using PyPlot

failed with

ERROR: InitError: PyError (PyImport_ImportModule

The Python package matplotlib could not be imported by pyimport. Usually this means
that you did not install matplotlib in the Python version being used by PyCall.

PyCall is currently configured to use the Python version at:


Trying using PyPlot from the REPL got the same result.

I do not use python at all and I am in over my head.

I will go back to 1.6.3 or try the intel version of 1.7 on my M1 mac.

Same issue with PyPlot in the REPL for 1.7.1.

Back to intel and rosetta

I figured out my problem.


somehow got erased from my startup.jl. Putting it back and building PyCall and PyPlot did the job.

1 Like