How to use Gurobi 11 in Julia launched by Anaconda?

I have updated my Julia to 1.10.2 indeed, and the version of Gurobi.jl is 1.2.1, all packages are newly installed for Julia 1.10.2.
I have also downloaded the newest Gurobi 11 and updated the licence which support Gurobi 11

When I run the solver, the version is still 9.5.0
Even when I try to run a Gurobi model in Julia’s terminal, it is also 9.5.0, same to Anaconda.

I hope to know how to run Gurobi 11 in JuMP?


1 Like

Try setting GUROBI_HOME to point to your new installation, then run import Pkg;"Gurobi"), and restart Julia for the change to take effect.

See GitHub - jump-dev/Gurobi.jl: Julia interface for Gurobi Optimizer

If it works, I should clarify the readme, since this comes up from time to time.

Thanks very much. I have tried the suggestions from this link and it does not works.

By the way, when I activate the newly obtained licence, I do it in Mac’s terminal, is that right?

Did you download Gurobi from Where is it installed?


I find the problem. When I look at “system/Library”, I find a “gurobi950” folder, and there is no gurobi11 folder… Should I delete it and re-install the new one?

But, when I use Python to run Gurobi, it is Gurobi 11…

You need to download and install Gurobi 11 from

Installing gurobipy on pip or conda automatically installs Gurobi, but Julia can’t easily use that version.

Thank you very much. I have fixed that. Gurobi 11 can be run on JuMP now.

I am very grateful

1 Like

Great! Let me know if you have any other questions

1 Like