How to transfer v0.6 package to v1?

package

#1

I am trying transfer some of my v0.6 packages to v1. I am a bit confused as how to do that at the moment. So I create the Project.toml and Manifest.toml and updated the github repo. Now I try to get into package mode by ] and I type in dev https://github.com/xiaodaigh/SortingLab.jl which should clone my repo into the Dev folder. But when I run using SortingLab it gives an error, and the error isn’t important, but it’s caused by dev url because it cloned an older version of the repo instead of updated one.

What’s the right way to migration from v0.6 to v1?


#2

Go to v0.7 first to get deprecation warnings, then transition to 1.0


#3

#4

My question is abt package development. My code works.


#5

It would help with understanding your problem if you post your error message. Did you try Pkg.resolve()?


#6

I stated the reason already


#7

Use dev https://github.com/xiaodaigh/SortingLab.jl#master if the new version has not been published through the registry yet (I assume you’re talking about a published package?).


#8

What do you mean by “older version”? The branch is not master? Or it is master but master is not at the most recent commit pushed to github?


#9

I have verified that the latest commit is indeed being cloned (on Julia 1.0.2).

What is probably happening here is that you ran dev, but the folder at e.g. .julia/dev/SortingLab already existed. In this case Pkg will not modify the already existing directory.

If you want to update it, you have to use git on the directory directly.


#10

This code doesn’t work. The error is “ERROR: invalid token”


#11

You have to type ] to switch the REPL to package mode.


#12

I did that. Maybe u try it


#13

Specifying branches are not supported for dev. Just use

dev https://github.com/xiaodaigh/SortingLab.jl

which should get you the master branch.


#14

Back to the original issue. It doesn’t get the latest updatex instead it gets the last release.

I solved it by cloning directly into the dev folder


#15

Well, you are probably running into https://github.com/JuliaLang/Pkg.jl/issues/465 then.