How to solve the problem of julia loading Moesk?

Downloaded a MosekTools, but when using MosekTools, it will ask to build (“Mosek”), and there are various problems when building, as shown in the figure

How to solve this problem, do I need to download a moesk software?


This seems to be an issue of PowerShell blocking the download script from running.

Before starting Julia, you can run this command:

PS> Unblock-File -Path C:\Users\30313\.julia\packages\Mosek\3NJdY\deps\winget.ps1

and then start Julia and try the again. This allows the download script from Mosek.jl to run, which should prevent this error.

(If for some reason you still get an error, you can also try:

PS> Set-ExecutionPolicy -ExecutionPolicy Bypass -Scope Process

before starting Julia.)

Thank you for your reply!
Since I’m just getting started, I don’t quite understand your solution, but I solved the problem with another solution.
I downloaded a Mosek software which automatically configures the environment variables and after getting the license I successfully used Mosektooks in Julia and got the results.