How to correctly install `julia-vim`?

I am trying to install the julia-vim plugin into vim.
I tried to use the built-in-package-management to install the package, as this is the most easy one.
But It seemed that nothing happend to my vim. When opening a .jl file, there is no julia style highlights, and the latex-to-unicode substitutiong does not work either.
I am not an export in vim, so I really have no clue what is going on here and how to trouble-shoot.
Here is the info returned by :version in vim:

VIM - Vi IMproved 8.1 (2018 May 18, compiled Feb 01 2022 09:16:32)
Included patches: 1-2269, 3612, 3625, 3669, 3741
Modified by
Compiled by
Huge version without GUI.  Features included (+) or not (-):
+acl               +cmdline_compl     +emacs_tags        +insert_expand     +modify_fname      +netbeans_intg     -ruby              +termguicolors     +visualextra
+arabic            +cmdline_hist      +eval              +job               +mouse             +num64             +scrollbind        +terminal          +viminfo
+autocmd           +cmdline_info      +ex_extra          +jumplist          -mouseshape        +packages          +signs             +terminfo          +vreplace
+autochdir         +comments          +extra_search      +keymap            +mouse_dec         +path_extra        +smartindent       +termresponse      +wildignore
-autoservername    +conceal           -farsi             +lambda            +mouse_gpm         -perl              +sound             +textobjects       +wildmenu
-balloon_eval      +cryptv            +file_in_path      +langmap           -mouse_jsbterm     +persistent_undo   +spell             +textprop          +windows
+balloon_eval_term +cscope            +find_in_path      +libcall           +mouse_netterm     +postscript        +startuptime       +timers            +writebackup
-browse            +cursorbind        +float             +linebreak         +mouse_sgr         +printer           +statusline        +title             -X11
++builtin_terms    +cursorshape       +folding           +lispindent        -mouse_sysmouse    +profile           -sun_workshop      -toolbar           -xfontset
+byte_offset       +dialog_con        -footer            +listcmds          +mouse_urxvt       -python            +syntax            +user_commands     -xim
+channel           +diff              +fork()            +localmap          +mouse_xterm       +python3           +tag_binary        +vartabs           -xpm
+cindent           +digraphs          +gettext           -lua               +multi_byte        +quickfix          -tag_old_static    +vertsplit         -xsmp
-clientserver      -dnd               -hangul_input      +menu              +multi_lang        +reltime           -tag_any_white     +virtualedit       -xterm_clipboard
-clipboard         -ebcdic            +iconv             +mksession         -mzscheme          +rightleft         -tcl               +visual            -xterm_save
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
 2nd user vimrc file: "~/.vim/vimrc"
      user exrc file: "$HOME/.exrc"
       defaults file: "$VIMRUNTIME/defaults.vim"
  fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H   -Wdate-time  -g -O2 -fdebug-prefix-map=/build/vim-9EpYYi/vim-8.1.2269=. -fstack-protector-strong -Wformat -Werror=format-security -D_REENT
Linking: gcc   -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -o vim        -lm -ltinfo -lnsl  -lselinux  -lcanberra -lacl -lattr -lgpm -ldl     -L/usr/lib/python3.8/conf
ig-3.8-x86_64-linux-gnu -lpython3.8 -lcrypt -lpthread -ldl -lutil -lm -lm

Any help is welcomed. Thanks in advance!

After installing following the built-in-package-management procedure I had also to switch syntax highlighting on with
:syntax on
or system wide in
~/vimrc will work too.

The Tab-completion did work without any changes just after installing as described (checked with \alpha).

But what I can’t get to work is :help julia-vim I get E149: Sorry, no help for julia-vim
VIM - Vi IMproved 8.1 (2018 May 18, compiled Dec 25 2021 15:48:51)

:scriptnames gives:

 20: ~/.vim/pack/plugins/start/julia-vim/ftdetect/julia.vim
 21: /usr/share/vim/vim81/syntax/lisp.vim
 22: ~/.vim/pack/plugins/start/julia-vim/autoload/LaTeXtoUnicode.vim
 23: ~/.vim/pack/plugins/start/julia-vim/autoload/julia_latex_symbols.vim
 24: ~/.vim/pack/plugins/start/julia-vim/syntax/julia.vim
 25: /usr/share/vim/vim81/syntax/vim.vim

Well, I finally moved to neovim, whose unpack-and-use version works quite fine.
As for your problem, have you tried :helptags ALL?

1 Like