How to clear old plots from Plot Navigator?

Hi, I can’t find a way to clear plots without restarting vscode completely. Is there a shortcut or a button for that? Here in the image there are old plots that I can’t clear from old runs. Restarting julia repl doesn’t do anything.

Does the Julia: Delete All Plots command work for you?
Note that that’s also in the plot pane title menu:
grafik

I can’t find that option. (Latest VSCode and Julia plugin)

Edit: I think there is a bug causing those options not to show but if I click on the title bar of the plot explorer they appear. I recorded a quick video of it, have a look: - YouTube

This seems to be because your code is still executing and producing graphs. I think you could access this command through the command palette (Ctrl+Shift+P - Cmd+Shift+P on Mac I think).

I tried it when the code finished executing in the video. The shown graph is a gif created by the code beforehand. I tried this with non-gif graphs too.

You’re right, I didn’t see this was a GIF. The delete all plots should be available, just in case that menu doesn’t show up for you. In my experience the plots panel is tied to the VS code extension, not the REPL, and restarting the REPL has never cleared my plots, which I think is intended.

Does the menu show up for static (not gif) plots? If it is only broken for GIFs, so then I would recommend filing a bug report with in VS code Julia extension repository.

It’s not only broken for gifs sadly, this happens for all plots. Tried reinstalling everything but that didn’t change anything.

Maybe it’s about Windows 11, I just formatted my drive and installed the OS.

My other guess is the screen scaling. I’m using %150 scaling in Windows settings. (high dpi screen, this is enabled by default)

This menu is sometimes a bit janky. Try clicking on the plot pane tab title or plot first.